Apache Zeppelin: Path traversal vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Improper Input Validation vulnerability in Apache Zeppelin. By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Zeppelin | 0.9.0 to before 0.11.0 | 0.11.0 | Patch available | CNA |
| — | org.apache.zeppelin:zeppelin-server (Maven) | 0.9.0 to before 0.11.0 | 0.11.0 | Patch available | GHSA-g64r-xf39-q4p5 |
- Apache Zeppelin VendorApache Affected 0.9.0 to before 0.11.0 Fixed in 0.11.0 Patch available CNA
- org.apache.zeppelin:zeppelin-server (Maven) Vendor— Affected 0.9.0 to before 0.11.0 Fixed in 0.11.0 Patch available GHSA-g64r-xf39-q4p5
Remediation
- Fix · CNA Apache Zeppelin (Apache Software Foundation) Fixed in 0.11.0
- Fix · GHSA-g64r-xf39-q4p5 org.apache.zeppelin:zeppelin-server (Maven) Fixed in 0.11.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Zeppelin 0.11.0
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2024-20980 Apache Zeppelin: Denial of service with invalid notebook namePriority LOW 33
- TI-2024-20981 Apache Zeppelin: Replacing other users notebook, bypassing any permissionsPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2024-31860
- 2026-10-03 Alias added: GHSA-g64r-xf39-q4p5
References
Advisory 2
More Apache Zeppelin vulnerabilities
- TI-2024-20984 Apache Zeppelin: Interpreter download command does not escape malicious code injection CVSS 3.1CRITICAL 9.8
- TI-2024-20982 Apache Zeppelin: Remote code execution by adding malicious JDBC connection string CVSS 3.1CRITICAL 9.8
- TI-2019-07420 bash command injection in spark interpreter CVSS 3.1CRITICAL 9.8
- TI-2018-01220 Improper authentication in Apache Zeppelin CVSS 3.0HIGH 8.8
- TI-2017-09344 Session fixation in Apache Zeppelin CVSS 3.0HIGH 8.1
- TI-2024-34954 Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string CVSS 3.1HIGH 7.5
Sources
- CVE-2024-31860 · CVE Program
- CVE-2024-31860 · NVD
- FIRST EPSS
- GHSA-g64r-xf39-q4p5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences