Read the docs
TI-2024-20983 Aliases CVE-2024-31865GHSA-g44m-x5h7-fr5q

Apache Zeppelin: Cron arbitrary user impersonation with improper privileges

Priority LOW 38CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

Improper Input Validation vulnerability in Apache Zeppelin. The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01723 77th percentileScored 2026-11-07
Fix Fixed Apache Zeppelin (Apache Software Foundation): 0.11.1org.apache.zeppelin:zeppelin-server (Maven): 0.11.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Zeppelin0.8.2 to before 0.11.10.11.1Patch availableCNA
—org.apache.zeppelin:zeppelin-server (Maven)0.8.2 to before 0.11.10.11.1Patch availableGHSA-g44m-x5h7-fr5q
  • Apache Zeppelin VendorApache Affected 0.8.2 to before 0.11.1 Fixed in 0.11.1 Patch available CNA
  • org.apache.zeppelin:zeppelin-server (Maven) Vendor— Affected 0.8.2 to before 0.11.1 Fixed in 0.11.1 Patch available GHSA-g44m-x5h7-fr5q

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:zeppelin:*:*:*:*:*:*:*:*0.8.2 to before 0.11.1VulnerableApache
  • cpe:2.3:a:apache:zeppelin:*:*:*:*:*:*:*:* Versions 0.8.2 to before 0.11.1 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Zeppelin (Apache Software Foundation) Fixed in 0.11.1
  • Fix · GHSA-g44m-x5h7-fr5q org.apache.zeppelin:zeppelin-server (Maven) Fixed in 0.11.1 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Zeppelin 0.11.1

    5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW

    Other records, highest priority first

    • TI-2024-20984 Apache Zeppelin: Interpreter download command does not escape malicious code injectionPriority MEDIUM 52
    • TI-2024-20982 Apache Zeppelin: Remote code execution by adding malicious JDBC connection stringPriority MEDIUM 51
    • TI-2024-20985 Apache Zeppelin: LDAP search filter query Injection VulnerabilityPriority LOW 31

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-31865
  2. 2026-10-03 Alias added: GHSA-g44m-x5h7-fr5q

References

  • TI-2024-20984 Apache Zeppelin: Interpreter download command does not escape malicious code injection CVSS 3.1CRITICAL 9.8
  • TI-2024-20982 Apache Zeppelin: Remote code execution by adding malicious JDBC connection string CVSS 3.1CRITICAL 9.8
  • TI-2019-07420 bash command injection in spark interpreter CVSS 3.1CRITICAL 9.8
  • TI-2018-01220 Improper authentication in Apache Zeppelin CVSS 3.0HIGH 8.8
  • TI-2017-09344 Session fixation in Apache Zeppelin CVSS 3.0HIGH 8.1
  • TI-2024-34954 Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string CVSS 3.1HIGH 7.5
See all 25 →

Sources