phlex makes Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
phlex is an open source framework for building object-oriented views in Ruby. There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. The filter to detect and prevent the use of the `javascript:` URL scheme in the `href` attribute of an `<a>` tag could be bypassed with tab `\t` or newline `\n` characters between the characters of the protocol, e.g. `java\tscript:`. This vulnerability is fixed in 1.10.1, 1.9.2, 1.8.3, 1.7.2, 1.6.3, 1.5.3, and 1.4.2. Configuring a Content Security Policy that does not allow `unsafe-inline` would effectively prevent this vulnerability from being exploited.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| phlex-ruby | phlex | 1.10.0 to before 1.10.1; 1.9.0 to before 1.9.2; 1.8.0 to before 1.8.3; 1.7.0 to before 1.7.2; 1.6.0 to before 1.6.3; 1.5.0 to before 1.5.3; 1.4.0 to before 1.4.2 | 1.10.1, 1.9.2, 1.8.3, 1.7.2, 1.6.3, 1.5.3, 1.4.2 | Patch available | CNA |
| — | phlex (RubyGems) | 1.10.0 to before 1.10.1 | 1.10.1 | Patch available | GHSA-g7xq-xv8c-h98c |
| — | phlex (RubyGems) | 1.9.0 to before 1.9.2 | 1.9.2 | Patch available | GHSA-g7xq-xv8c-h98c |
| — | phlex (RubyGems) | 1.8.0 to before 1.8.3 | 1.8.3 | Patch available | GHSA-g7xq-xv8c-h98c |
| — | phlex (RubyGems) | 1.7.0 to before 1.7.2 | 1.7.2 | Patch available | GHSA-g7xq-xv8c-h98c |
| — | phlex (RubyGems) | 1.6.0 to before 1.6.3 | 1.6.3 | Patch available | GHSA-g7xq-xv8c-h98c |
| — | phlex (RubyGems) | 1.5.0 to before 1.5.3 | 1.5.3 | Patch available | GHSA-g7xq-xv8c-h98c |
| — | phlex (RubyGems) | before 1.4.2 | 1.4.2 | Patch available | GHSA-g7xq-xv8c-h98c |
- phlex Vendorphlex-ruby Affected 1.10.0 to before 1.10.1; 1.9.0 to before 1.9.2; 1.8.0 to before 1.8.3; 1.7.0 to before 1.7.2; 1.6.0 to before 1.6.3; 1.5.0 to before 1.5.3; 1.4.0 to before 1.4.2 Fixed in 1.10.1, 1.9.2, 1.8.3, 1.7.2, 1.6.3, 1.5.3, 1.4.2 Patch available CNA
- phlex (RubyGems) Vendor— Affected 1.10.0 to before 1.10.1 Fixed in 1.10.1 Patch available GHSA-g7xq-xv8c-h98c
- phlex (RubyGems) Vendor— Affected 1.9.0 to before 1.9.2 Fixed in 1.9.2 Patch available GHSA-g7xq-xv8c-h98c
- phlex (RubyGems) Vendor— Affected 1.8.0 to before 1.8.3 Fixed in 1.8.3 Patch available GHSA-g7xq-xv8c-h98c
- phlex (RubyGems) Vendor— Affected 1.7.0 to before 1.7.2 Fixed in 1.7.2 Patch available GHSA-g7xq-xv8c-h98c
- phlex (RubyGems) Vendor— Affected 1.6.0 to before 1.6.3 Fixed in 1.6.3 Patch available GHSA-g7xq-xv8c-h98c
- phlex (RubyGems) Vendor— Affected 1.5.0 to before 1.5.3 Fixed in 1.5.3 Patch available GHSA-g7xq-xv8c-h98c
- phlex (RubyGems) Vendor— Affected before 1.4.2 Fixed in 1.4.2 Patch available GHSA-g7xq-xv8c-h98c
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ruby:fileutils:1.0.0:*:*:*:*:*:*:* | 1.0.0 | — | — |
- cpe:2.3:a:ruby:fileutils:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 — ·—
Remediation
- Fix · CNA phlex (phlex-ruby) Fixed in 1.10.1, 1.9.2, 1.8.3, 1.7.2, 1.6.3, 1.5.3, 1.4.2
- Fix · GHSA-g7xq-xv8c-h98c phlex (RubyGems) Fixed in 1.10.1 Advisory →
- Fix · GHSA-g7xq-xv8c-h98c phlex (RubyGems) Fixed in 1.9.2 Advisory →
- Fix · GHSA-g7xq-xv8c-h98c phlex (RubyGems) Fixed in 1.8.3 Advisory →
- Fix · GHSA-g7xq-xv8c-h98c phlex (RubyGems) Fixed in 1.7.2 Advisory →
- Fix · GHSA-g7xq-xv8c-h98c phlex (RubyGems) Fixed in 1.6.3 Advisory →
- Fix · GHSA-g7xq-xv8c-h98c phlex (RubyGems) Fixed in 1.5.3 Advisory →
- Fix · GHSA-g7xq-xv8c-h98c phlex (RubyGems) Fixed in 1.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32463
- 2026-10-03 Alias added: GHSA-g7xq-xv8c-h98c
References
Other 6
- https://github.com/phlex-ruby/phlex/security/advisories/GHSA-g7xq-xv8c-h98c
- https://github.com/phlex-ruby/phlex/commit/9e3f5b980655817993682e409cbda72956d865cb
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline
- https://github.com/phlex-ruby/phlex
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/phlex/CVE-2024-32463.yml
More phlex-ruby vulnerabilities
- TI-2024-21836 Cross-site Scripting (XSS) possible with maliciously formed HTML attribute names and values in Phlex CVSS 3.1HIGH 7.1
Sources
- CVE-2024-32463 · CVE Program
- CVE-2024-32463 · NVD
- FIRST EPSS
- GHSA-g7xq-xv8c-h98c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences