Cross-site Scripting (XSS) possible with maliciously formed HTML attribute names and values in Phlex
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Phlex is a framework for building object-oriented views in Ruby. In affected versions there is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. Since the last two vulnerabilities https://github.com/phlex-ruby/phlex/security/advisories/GHSA-242p-4v39-2v8g and https://github.com/phlex-ruby/phlex/security/advisories/GHSA-g7xq-xv8c-h98c, we have invested in extensive browser tests. It was these new tests that helped us uncover these issues. As of now the project exercises every possible attack vector the developers can think of — including enumerating every ASCII character, and we run these tests in Chrome, Firefox and Safari. Additionally, we test against a list of 6613 known XSS payloads (see: payloadbox/xss-payload-list). The reason these issues were not detected before is the escapes were working as designed. However, their design didn't take into account just how recklessly permissive browsers are when it comes to executing unsafe JavaScript via HTML attributes. If you render an `<a>` tag with an `href` attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user. If you splat user-provided attributes when rendering any HTML or SVG tag, malicious event attributes could be included in the output, executing JavaScript when the events are triggered by another user. Patches are available on RubyGems for all minor versions released in the last year. Users are advised to upgrade. Users unable to upgrade should configure a Content Security Policy that does not allow `unsafe-inline` which would effectively prevent this vulnerability from being exploited. Users who upgrade are also advised to configure a Content Security Policy header that does not allow `unsafe-inline`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| phlex-ruby | phlex | before 1.9.3; 1.10.0 to before 1.10.2 | 1.9.3, 1.10.2 | Patch available | CNA |
| — | phlex (RubyGems) | before 1.9.3 | 1.9.3 | Patch available | GHSA-9p57-h987-4vgx |
| — | phlex (RubyGems) | 1.10.0 to before 1.10.2 | 1.10.2 | Patch available | GHSA-9p57-h987-4vgx |
- phlex Vendorphlex-ruby Affected before 1.9.3; 1.10.0 to before 1.10.2 Fixed in 1.9.3, 1.10.2 Patch available CNA
- phlex (RubyGems) Vendor— Affected before 1.9.3 Fixed in 1.9.3 Patch available GHSA-9p57-h987-4vgx
- phlex (RubyGems) Vendor— Affected 1.10.0 to before 1.10.2 Fixed in 1.10.2 Patch available GHSA-9p57-h987-4vgx
Remediation
- Fix · CNA phlex (phlex-ruby) Fixed in 1.9.3, 1.10.2
- Fix · GHSA-9p57-h987-4vgx phlex (RubyGems) Fixed in 1.9.3 Advisory →
- Fix · GHSA-9p57-h987-4vgx phlex (RubyGems) Fixed in 1.10.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32970
- 2026-10-03 Alias added: GHSA-9p57-h987-4vgx
References
Other 10
- https://github.com/phlex-ruby/phlex/security/advisories/GHSA-9p57-h987-4vgx
- https://github.com/phlex-ruby/phlex/commit/da8f94342a84cff9d78c98bcc3b3604ee2e577d2
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline
- https://github.com/payloadbox/xss-payload-list
- https://rubygems.org/gems/phlex
- https://github.com/phlex-ruby/phlex
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/phlex/CVE-2024-32970.yml
- https://rubygems.org/gems/phlex/versions/1.10.2
- https://rubygems.org/gems/phlex/versions/1.9.3
More phlex-ruby vulnerabilities
- TI-2024-21358 phlex makes Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags CVSS 3.1HIGH 7.1
Sources
- CVE-2024-32970 · CVE Program
- CVE-2024-32970 · NVD
- FIRST EPSS
- GHSA-9p57-h987-4vgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences