Decidim has cross-site scripting (XSS) in the pagination
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter `per_page`. This vulnerability is fixed in 0.27.6 and 0.28.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00417 36th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.27.6, 0.28.1decidim (RubyGems): 0.27.6, 0.28.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| decidim | decidim | before 0.27.6; 0.28.0.rc1 to before 0.28.1 | 0.27.6, 0.28.1 | Patch available | CNA |
| — | decidim (RubyGems) | before 0.27.6 | 0.27.6 | Patch available | GHSA-7cx8-44pc-xv3q |
| — | decidim (RubyGems) | 0.28.0.rc1 to before 0.28.1 | 0.28.1 | Patch available | GHSA-7cx8-44pc-xv3q |
- decidim Vendordecidim Affected before 0.27.6; 0.28.0.rc1 to before 0.28.1 Fixed in 0.27.6, 0.28.1 Patch available CNA
- decidim (RubyGems) Vendor— Affected before 0.27.6 Fixed in 0.27.6 Patch available GHSA-7cx8-44pc-xv3q
- decidim (RubyGems) Vendor— Affected 0.28.0.rc1 to before 0.28.1 Fixed in 0.28.1 Patch available GHSA-7cx8-44pc-xv3q
Remediation
- Fix · CNA decidim (decidim) Fixed in 0.27.6, 0.28.1
- Fix · GHSA-7cx8-44pc-xv3q decidim (RubyGems) Fixed in 0.27.6 Advisory →
- Fix · GHSA-7cx8-44pc-xv3q decidim (RubyGems) Fixed in 0.28.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32469
- 2026-10-03 Alias added: GHSA-7cx8-44pc-xv3q
References
Other 5
- https://github.com/decidim/decidim/security/advisories/GHSA-7cx8-44pc-xv3q
- https://github.com/decidim/decidim/releases/tag/v0.27.6
- https://github.com/decidim/decidim/releases/tag/v0.28.1
- https://github.com/decidim/decidim
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2024-32469.yml
More decidim vulnerabilities
- TI-2026-33169 Decidim: Verification documents can be downloaded through reusable links CVSS 3.1HIGH 7.5
- TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
- TI-2026-33203 Decidim: JWT-backed authentication can be replayed across organizations CVSS 3.1HIGH 8.5
- TI-2026-33168 Decidim: Private exports can be downloaded through reusable links CVSS 3.1MEDIUM 6.5
- TI-2026-33204 Decidim: CSV census record endpoints improper authorization CVSS 3.1MEDIUM 6.0
- TI-2026-33167 Decidim: Admin user search allows SQL injection through similarity-based sorting CVSS 3.1MEDIUM 5.5
Sources
- CVE-2024-32469 · CVE Program
- CVE-2024-32469 · NVD
- FIRST EPSS
- GHSA-7cx8-44pc-xv3q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences