Decidim's private data exports can lead to data leaks
Priority HIGH 71CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Decidim is a participatory democracy framework. In versions from 0.30.0 to before 0.30.4 and from 0.31.0.rc1 to before 0.31.0, the private data exports can lead to data leaks in case the UUID generation, causing collisions for the generated UUIDs. This issue has been patched in versions 0.30.4 and 0.31.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00313 24th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.30.4, 0.31.0decidim-core (RubyGems): 0.30.4+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| decidim | decidim | 0.30.0 to before 0.30.4; 0.31.0.r1 to before 0.31.0 | 0.30.4, 0.31.0 | Patch available | CNA |
| — | decidim-core (RubyGems) | 0.30.0 to before 0.30.4 | 0.30.4 | Patch available | GHSA-3cx6-j9j4-54mp |
| — | decidim (RubyGems) | 0.30.0 to before 0.30.4 | 0.30.4 | Patch available | GHSA-3cx6-j9j4-54mp |
- decidim Vendordecidim Affected 0.30.0 to before 0.30.4; 0.31.0.r1 to before 0.31.0 Fixed in 0.30.4, 0.31.0 Patch available CNA
- decidim-core (RubyGems) Vendor— Affected 0.30.0 to before 0.30.4 Fixed in 0.30.4 Patch available GHSA-3cx6-j9j4-54mp
- decidim (RubyGems) Vendor— Affected 0.30.0 to before 0.30.4 Fixed in 0.30.4 Patch available GHSA-3cx6-j9j4-54mp
Remediation
- Fix · CNA decidim (decidim) Fixed in 0.30.4, 0.31.0
- Fix · GHSA-3cx6-j9j4-54mp decidim-core (RubyGems) Fixed in 0.30.4 Advisory →
- Fix · GHSA-3cx6-j9j4-54mp decidim (RubyGems) Fixed in 0.30.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-65017
- 2026-10-03 Alias added: GHSA-3cx6-j9j4-54mp
References
Advisory 2
Other 5
- https://github.com/decidim/decidim/releases/tag/v0.30.4
- https://github.com/decidim/decidim/releases/tag/v0.31.0
- https://github.com/decidim/decidim
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2025-65017.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2025-65017.yml
More Decidim vulnerabilities
- TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
- TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
- TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
- TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
- TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
- TI-2026-29525 Decidim amendments can be accepted or rejected by anyone CVSS 3.1HIGH 7.5
Sources
- CVE-2025-65017 · CVE Program
- CVE-2025-65017 · NVD
- FIRST EPSS
- GHSA-3cx6-j9j4-54mp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences