Read the docs
TI-2024-21368 Aliases CVE-2024-32474GHSA-6cjm-4pxw-7xp9

Sentry's superuser cleartext password leaked in logs

Priority LOW 32CWE-117Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-312.

Summary

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00428 37th percentileScored 2026-11-07
Fix Fixed sentry (getsentry): 24.4.1sentry (PyPI): 24.4.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getsentrysentry24.3.0 to before 24.4.124.4.1Patch availableCNA
—sentry (PyPI)24.3.0 to before 24.4.124.4.1Patch availableGHSA-6cjm-4pxw-7xp9
  • sentry Vendorgetsentry Affected 24.3.0 to before 24.4.1 Fixed in 24.4.1 Patch available CNA
  • sentry (PyPI) Vendor— Affected 24.3.0 to before 24.4.1 Fixed in 24.4.1 Patch available GHSA-6cjm-4pxw-7xp9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sentry:sentry:*:*:*:*:*:*:*:*24.3.0 to before 24.4.1VulnerableSentry
  • cpe:2.3:a:sentry:sentry:*:*:*:*:*:*:*:* Versions 24.3.0 to before 24.4.1 Vulnerable ·Sentry

Remediation

  • Fix · CNA sentry (getsentry) Fixed in 24.4.1
  • Fix · GHSA-6cjm-4pxw-7xp9 sentry (PyPI) Fixed in 24.4.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-32474
  2. 2026-10-03 Alias added: GHSA-6cjm-4pxw-7xp9

References

  • TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
  • TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
  • TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
  • TI-2025-16094 Improper authentication on SAML SSO process allows user impersonation in sentry CVSS 3.1CRITICAL 9.1
  • TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
  • TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
See all 28 →

Sources