Envoy RELEASE_ASSERT using auto_sni with :authority header > 255 bytes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-617.
Summary
Envoy is a cloud-native, open source edge and service proxy. When an upstream TLS cluster is used with `auto_sni` enabled, a request containing a `host`/`:authority` header longer than 255 characters triggers an abnormal termination of Envoy process. Envoy does not gracefully handle an error when setting SNI for outbound TLS connection. The error can occur when Envoy attempts to use the `host`/`:authority` header value longer than 255 characters as SNI for outbound TLS connection. SNI length is limited to 255 characters per the standard. Envoy always expects this operation to succeed and abnormally aborts the process when it fails. This vulnerability is fixed in 1.30.1, 1.29.4, 1.28.3, and 1.27.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | 1.30.0 to before 1.30.1; 1.29.0 to before 1.29.4; 1.28.0 to before 1.28.3; 1.13.0 to before 1.27.5 | 1.30.1, 1.29.4, 1.28.3, 1.27.5 | Patch available | CNA |
- envoy Vendorenvoyproxy Affected 1.30.0 to before 1.30.1; 1.29.0 to before 1.29.4; 1.28.0 to before 1.28.3; 1.13.0 to before 1.27.5 Fixed in 1.30.1, 1.29.4, 1.28.3, 1.27.5 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | 1.13.0 to before 1.27.5; 1.28.0 to before 1.28.3; 1.29.0 to before 1.29.4 | Vulnerable | envoyproxy |
| cpe:2.3:a:envoyproxy:envoy:1.30.0:*:*:*:*:*:*:* | 1.30.0 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions 1.13.0 to before 1.27.5; 1.28.0 to before 1.28.3; 1.29.0 to before 1.29.4 Vulnerable ·envoyproxy
- cpe:2.3:a:envoyproxy:envoy:1.30.0:*:*:*:*:*:*:* Versions 1.30.0 Vulnerable ·envoyproxy
Remediation
- Fix · CNA envoy (envoyproxy) Fixed in 1.30.1, 1.29.4, 1.28.3, 1.27.5
Red Hat 2 advisories
- RHSA-2024:7725 Released 2024-10-07 · Red Hat rating ImportantRed Hat OpenShift Service Mesh Containers for 2.5.5
- RHOSSM 2.5 for RHEL 8 openshift-service-mesh/grafana-rhel8, openshift-service-mesh/istio-cni-rhel8, openshift-service-mesh/istio-must-gather-rhel8 +5
- RHSA-2024:7724 Released 2024-10-07 · Red Hat rating ImportantRed Hat OpenShift Service Mesh Containers for 2.4.11
- RHOSSM 2.4 for RHEL 8 openshift-service-mesh/grafana-rhel8, openshift-service-mesh/istio-cni-rhel8, openshift-service-mesh/istio-must-gather-rhel8 +4
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 2 | Affected | No fix planned: Will not fix |
| RHOSSM 2.4 for RHEL 8 | Fixed | RHSA-2024:7724 |
| RHOSSM 2.5 for RHEL 8 | Fixed | RHSA-2024:7725 |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32475
- 2026-11-05 Affected versions changed · CNA
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-32475 · CVE Program
- CVE-2024-32475 · NVD
- FIRST EPSS
- CVE-2024-32475 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences