Apache APISIX: Forward-Auth Request Smuggling
Priority LOW 30CWE-444Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01065 64th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache APISIX | 3.8.0 – 3.9.0 | — | No fix listed | CNA |
- Apache APISIX VendorApache Affected 3.8.0 – 3.9.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32638
- 2026-10-03 Alias added: GHSA-8g74-32fg-5ghc
References
More Apache Apisix vulnerabilities
- TI-2022-08057 apisix/batch-requests plugin allows overwriting the X-REAL-IP header KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2020-10921 In Apache APISIX, the user enabled the Admin API and deleted the Admin API access IP… CVSS 3.1MEDIUM 6.5
- TI-2026-24457 Apache APISIX: forward auth plugin allows header injection CVSS 3.1CRITICAL 9.1
- TI-2022-09331 Apache APISIX: the body_schema check in request-validation plugin can be bypassed CVSS 3.1CRITICAL 9.8
- TI-2021-19447 Path traversal in request_uri variable CVSS 3.1HIGH 7.5
Sources
- CVE-2024-32638 · CVE Program
- CVE-2024-32638 · NVD
- FIRST EPSS
- GHSA-8g74-32fg-5ghc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences