Read the docs

Apache

Records4054All Threatist records
Exploited (KEV)47In CISA KEV
CVSS critical776CVSS 9.0–10.0
CVSS high1543CVSS 7.0–8.9

Exploited now

Apache records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

29 records in Apisix · all components

TI-2021-19447 CVE-2021-43557 · GHSA-9wxc-375c-cvq2

Path traversal in request_uri variable

Priority MEDIUM 47

The uri-block plugin in Apache APISIX before 2.10.2 uses $request_uri without verification.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.13044 Published 2021-11-22 No fix listed CWE-77
Priority MEDIUM 44

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0814 Published 2022-04-20 No fix listed CWE-209
Priority LOW 39

Sensitive data exposure via logging in basic-auth leads to plaintext usernames and passwords written to error logs and forwarded to log sinks when log level is INFO/DEBUG.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0048 Published 2025-10-31 Fixed in 3.14 CWE-532
Priority LOW 35

Authentication Bypass by Capture-replay vulnerability in Apache APISIX.

CVSS 4.0MEDIUM 6.3 Network No auth No interaction EPSS 0.00689 Published 2026-06-19 No fix listed CWE-294
Priority LOW 30

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0.

CVSS 3.1MEDIUM 6.3 Network Low privileges No interaction EPSS 0.01065 Published 2024-05-02 No fix listed CWE-444
Load more
Open these records in search →