Email addresses of remote users visible in props regardless of server settings
Priority LOW 19CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284 and CWE-312.
Summary
Mattermost versions 9.9.x <= 9.9.1, 9.5.x <= 9.5.7, 9.10.x <= 9.10.0, 9.8.x <= 9.8.2, when shared channels are enabled, fail to redact remote users' original email addresses stored in user props when email addresses are otherwise configured not to be visible in the local server."
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0022 12th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 9.11.0, 9.9.2, 9.5.8 +2github.com/mattermost/mattermost/server/v8 (Go): 9.9.2, 9.5.8, 9.10.1 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 9.9.0 – 9.9.1; 9.5.0 – 9.5.7; 9.10.0; 9.8.0 – 9.8.2 | 9.11.0, 9.9.2, 9.5.8, 9.10.1, 9.8.3 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.9.0 to before 9.9.2 | 9.9.2 | Patch available | GHSA-4ww8-fprq-cq34 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.5.0 to before 9.5.8 | 9.5.8 | Patch available | GHSA-4ww8-fprq-cq34 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.10.0 to before 9.10.1 | 9.10.1 | Patch available | GHSA-4ww8-fprq-cq34 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.8.0 to before 9.8.3 | 9.8.3 | Patch available | GHSA-4ww8-fprq-cq34 |
- Mattermost VendorMattermost Affected 9.9.0 – 9.9.1; 9.5.0 – 9.5.7; 9.10.0; 9.8.0 – 9.8.2 Fixed in 9.11.0, 9.9.2, 9.5.8, 9.10.1, 9.8.3 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.9.0 to before 9.9.2 Fixed in 9.9.2 Patch available GHSA-4ww8-fprq-cq34
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.5.0 to before 9.5.8 Fixed in 9.5.8 Patch available GHSA-4ww8-fprq-cq34
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.10.0 to before 9.10.1 Fixed in 9.10.1 Patch available GHSA-4ww8-fprq-cq34
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.8.0 to before 9.8.3 Fixed in 9.8.3 Patch available GHSA-4ww8-fprq-cq34
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* | 9.5.0 to before 9.5.8; 9.8.0 to before 9.8.3; 9.9.0 to before 9.9.2; 9.10.0 to before 9.10.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* Versions 9.5.0 to before 9.5.8; 9.8.0 to before 9.8.3; 9.9.0 to before 9.9.2; 9.10.0 to before 9.10.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.11.0, 9.9.2, 9.5.8, 9.10.1, 9.8.3
- Fix · GHSA-4ww8-fprq-cq34 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.9.2 Advisory →
- Fix · GHSA-4ww8-fprq-cq34 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.5.8 Advisory →
- Fix · GHSA-4ww8-fprq-cq34 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.10.1 Advisory →
- Fix · GHSA-4ww8-fprq-cq34 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.8.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32939
- 2026-10-03 Alias added: GHSA-4ww8-fprq-cq34
References
More Mattermost vulnerabilities
- TI-2024-26695 Malicious remote can invite itself to an arbitrary local channel CVSS 3.1CRITICAL 9.6
- TI-2023-02056 Oauth authorization codes do not expire when deauthorizing an oauth2 app CVSS 3.1CRITICAL 9.1
- TI-2019-15069 An issue was discovered in Mattermost Mobile Apps before 1.26.0. CVSS 3.1CRITICAL 9.1
- TI-2024-26233 Malicious remote can add users to arbitrary teams and channels CVSS 3.1HIGH 8.7
- TI-2024-26746 Permanently local data deletion by malicious remote CVSS 3.1HIGH 8.7
- TI-2023-06508 Injection in Mattermost CVSS 3.1HIGH 8.8
Sources
- CVE-2024-32939 · CVE Program
- CVE-2024-32939 · NVD
- FIRST EPSS
- GHSA-4ww8-fprq-cq34 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences