ThinkPHP 8.0.3 allows remote attackers to exploit XSS due to inadequate filtering of…
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ThinkPHP 8.0.3 allows remote attackers to exploit XSS due to inadequate filtering of function argument values in think_exception.tpl.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00417 36th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed topthink/framework (Packagist): 8.0.4, 6.1.5, 6.0.17
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | topthink/framework (Packagist) | 8.0.0 to before 8.0.4 | 8.0.4 | Patch available | GHSA-969f-v7jv-pgj3 |
| — | topthink/framework (Packagist) | 6.1.0 to before 6.1.5 | 6.1.5 | Patch available | GHSA-969f-v7jv-pgj3 |
| — | topthink/framework (Packagist) | before 6.0.17 | 6.0.17 | Patch available | GHSA-969f-v7jv-pgj3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- topthink/framework (Packagist) Vendor— Affected 8.0.0 to before 8.0.4 Fixed in 8.0.4 Patch available GHSA-969f-v7jv-pgj3
- topthink/framework (Packagist) Vendor— Affected 6.1.0 to before 6.1.5 Fixed in 6.1.5 Patch available GHSA-969f-v7jv-pgj3
- topthink/framework (Packagist) Vendor— Affected before 6.0.17 Fixed in 6.0.17 Patch available GHSA-969f-v7jv-pgj3
Remediation
- Fix · GHSA-969f-v7jv-pgj3 topthink/framework (Packagist) Fixed in 8.0.4 Advisory →
- Fix · GHSA-969f-v7jv-pgj3 topthink/framework (Packagist) Fixed in 6.1.5 Advisory →
- Fix · GHSA-969f-v7jv-pgj3 topthink/framework (Packagist) Fixed in 6.0.17 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34467
- 2026-10-03 Alias added: GHSA-969f-v7jv-pgj3
References
Other 4
More Thinkphp vulnerabilities
- TI-2019-06557 ThinkPHP before 3.2.4, as used in Open Source BMS v1.1.1 and other products, allows… KEVCVSS 3.1HIGH 8.8
- TI-2025-32227 An issue in thinkphp3 v.3.2.5 allows a remote attacker to execute arbitrary code via the index.php component CVSS 3.1CRITICAL 9.8
- TI-2025-32226 An issue in thinkphp v.5.1 allows a remote attacker to execute arbitrary code via the routecheck function CVSS 3.1CRITICAL 9.8
- TI-2024-32271 A deserialization vulnerability in the component \controller\Index.php of Thinkphp v6.1.3… CVSS 3.1CRITICAL 9.8
- TI-2024-30031 A deserialization vulnerability in Thinkphp v6.1.3 to v8.0.4 allows attackers to execute arbitrary code. CVSS 3.1CRITICAL 9.8
- TI-2022-23758 ThinkPHP Framework before 6.0.14 allows local file inclusion via the lang parameter when… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-34467 · CVE Program
- CVE-2024-34467 · NVD
- FIRST EPSS
- GHSA-969f-v7jv-pgj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences