Wordpress Advanced Custom Fields Pro plugin < 6.2.10 - Contributor+ Arbitrary Function Execution vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
Vulnerability discovered by executing a planned security audit. Improper Control of Generation of Code ('Code Injection') vulnerability in WPENGINE INC Advanced Custom Fields PRO allows Code Injection.This issue affects Advanced Custom Fields PRO: from n/a before 6.2.10.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpengine | Advanced Custom Fields PRO | before 6.2.10 | 6.2.10 | Patch available | CNA |
- Advanced Custom Fields PRO Vendorwpengine Affected before 6.2.10 Fixed in 6.2.10 Patch available CNA
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:* | — | — | Advanced Custom Fields |
- cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:* Versions — — ·Advanced Custom Fields
Remediation
- Fix · CNA Advanced Custom Fields PRO (WPENGINE INC) Fixed in 6.2.10
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WPENGINE Advanced Custom Fields PRO 6.2.10
2 records Highest priority Priority HIGH 1 HIGH, 1 LOW
Other records, highest priority first
- TI-2024-23053 Wordpress Advanced Custom Fields Pro plugin < 6.2.10 - Contributor+ Local File Inclusion vulnerabilityPriority HIGH 76
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34761
- 2026-10-03 Alias added: GHSA-qfhh-q5qc-jq7h
More wpengine vulnerabilities
- TI-2023-06336 Better Search Replace <= 1.4.4 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2024-23053 Wordpress Advanced Custom Fields Pro plugin < 6.2.10 - Contributor+ Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.9
- TI-2019-07258 The WPGraphQL 0.2.3 plugin for WordPress allows remote attackers to register a new user… CVSS 3.0CRITICAL 9.8
- TI-2019-07259 An issue was discovered in the WPGraphQL 0.2.3 plugin for WordPress. CVSS 3.0CRITICAL 9.1
- TI-2024-03640 Genesis Blocks <= 3.1.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2022-01434 WPGraphQL WooCommerce <= 0.11.0 - Unauthenticated Coupon Codes Disclosure CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-34761 · CVE Program
- CVE-2024-34761 · NVD
- FIRST EPSS
- GHSA-qfhh-q5qc-jq7h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences