WordPress Fastly plugin <= 1.2.25 - Broken Access Control vulnerability
Priority LOW 20CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
Missing Authorization vulnerability in Fastly.This issue affects Fastly: from n/a through 1.2.25.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00277 20th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34803
- 2026-10-03 Alias added: GHSA-mh9w-chrg-w8jh
References
More Fastly vulnerabilities
- TI-2025-07937 A mismatch caused by client-triggered server-sent stream resets between HTTP/2… CVSS 3.1HIGH 7.5
- TI-2022-18597 Random number seed fixed during compilation CVSS 3.1HIGH 7.5
- TI-2017-10034 The Fastly CDN module before 1.2.26 for Magento2, when used with a third-party… CVSS 3.0MEDIUM 6.5
- TI-2015-08022 Fastly Plugin api.php post cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2024-25632 @fastly/js-compute use-after-free in some host call implementations CVSS 3.1MEDIUM 5.3
- TI-2024-23058 WordPress Fastly plugin <= 1.2.25 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-34803 · CVE Program
- CVE-2024-34803 · NVD
- FIRST EPSS
- GHSA-mh9w-chrg-w8jh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences