@fastly/js-compute use-after-free in some host call implementations
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
@fastly/js-compute is a JavaScript SDK and runtime for building Fastly Compute applications. The implementation of several functions were determined to include a use-after-free bug. This bug could allow for unintended data loss if the result of the preceding functions were sent anywhere else, and often results in a guest trap causing services to return a 500. This bug has been fixed in version 3.16.0 of the `@fastly/js-compute` package.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Fastly | js-compute-runtime | 3.0.0 to before 3.16.0 | 3.16.0 | Patch available | CNA |
| — | @fastly/js-compute (npm) | 3.0.0 to before 3.16.0 | 3.16.0 | Patch available | GHSA-mp3g-vpm9-9vqv |
- js-compute-runtime VendorFastly Affected 3.0.0 to before 3.16.0 Fixed in 3.16.0 Patch available CNA
- @fastly/js-compute (npm) Vendor— Affected 3.0.0 to before 3.16.0 Fixed in 3.16.0 Patch available GHSA-mp3g-vpm9-9vqv
Remediation
- Fix · CNA js-compute-runtime (fastly) Fixed in 3.16.0
- Fix · GHSA-mp3g-vpm9-9vqv @fastly/js-compute (npm) Fixed in 3.16.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38375
- 2026-10-03 Alias added: GHSA-mp3g-vpm9-9vqv
References
More Fastly vulnerabilities
- TI-2025-07937 A mismatch caused by client-triggered server-sent stream resets between HTTP/2… CVSS 3.1HIGH 7.5
- TI-2022-18597 Random number seed fixed during compilation CVSS 3.1HIGH 7.5
- TI-2017-10034 The Fastly CDN module before 1.2.26 for Magento2, when used with a third-party… CVSS 3.0MEDIUM 6.5
- TI-2015-08022 Fastly Plugin api.php post cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2024-23058 WordPress Fastly plugin <= 1.2.25 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-23090 WordPress Fastly plugin <= 1.2.25 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-38375 · CVE Program
- CVE-2024-38375 · NVD
- FIRST EPSS
- GHSA-mp3g-vpm9-9vqv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences