Apache OFBiz: Path traversal leading to a RCE
Priority HIGH 83CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 18.12.14. Users are recommended to upgrade to version 18.12.14, which fixes the issue.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.87883 99th percentileScored 2026-11-07
Fix Fixed Apache OFBiz (Apache Software Foundation): 18.12.14
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Apache OFBiz (Apache Software Foundation) Fixed in 18.12.14
Timeline
- 2026-10-02 Threatist record created from CVE-2024-36104
- 2026-10-03 Alias added: GHSA-77m3-6865-xvqj
- 2026-11-03 CISA SSVC decision points changed
References
More Apache Ofbiz vulnerabilities
- TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26062 Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code KEVCVSS 3.1CRITICAL 9.8
- TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2024-30542 Apache OFBiz: Prevent use of URLs in files when loading them from Java or Groovy, leading to a RCE CVSS 3.1CRITICAL 9.8
- TI-2021-08129 RCE vulnerability in latest Apache OFBiz due to Java serialisation using RMI CVSS 3.1CRITICAL 9.8
- TI-2023-28119 Apache OFBiz: Pre-authentication Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-36104 · CVE Program
- CVE-2024-36104 · NVD
- FIRST EPSS
- GHSA-77m3-6865-xvqj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences