Authentication bypass in VMware ESXi
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-287.
Summary
VMware ESXi contains an authentication bypass vulnerability. A malicious actor with sufficient Active Directory (AD) permissions can gain full access to an ESXi host that was previously configured to use AD for user management https://blogs.vmware.com/vsphere/2012/09/joining-vsphere-hosts-to-active-directory.html by re-creating the configured AD group ('ESXi Admins' by default) after it was deleted from AD.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | VMware ESXi | 8.0 to before ESXi80U3-24022510; 7.0 | ESXi80U3-24022510 | Patch available | CNA |
| — | VMware Cloud Foundation | 5.x; 4.x | — | No fix listed | CNA |
- VMware ESXi Vendor— Affected 8.0 to before ESXi80U3-24022510; 7.0 Fixed in ESXi80U3-24022510 Patch available CNA
- VMware Cloud Foundation Vendor— Affected 5.x; 4.x Fixed in — No fix listed CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:cloud_foundation:*:*:*:*:*:*:*:* | 4.0 to before 5.2 | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:-:*:*:*:*:*:* | 8.0 | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:a:*:*:*:*:*:* | 8.0 a | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:b:*:*:*:*:*:* | 8.0 b | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:c:*:*:*:*:*:* | 8.0 c | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:update_1:*:*:*:*:*:* | 8.0 update_1 | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:update_1a:*:*:*:*:*:* | 8.0 update_1a | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:update_1c:*:*:*:*:*:* | 8.0 update_1c | Vulnerable | VMware |
| cpe:2.3:o:vmware:esxi:8.0:update_1d:*:*:*:*:*:* | 8.0 update_1d | Vulnerable | VMware |
- cpe:2.3:a:vmware:cloud_foundation:*:*:*:*:*:*:*:* Versions 4.0 to before 5.2 Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:-:*:*:*:*:*:* Versions 8.0 Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:a:*:*:*:*:*:* Versions 8.0 a Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:b:*:*:*:*:*:* Versions 8.0 b Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:c:*:*:*:*:*:* Versions 8.0 c Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:update_1:*:*:*:*:*:* Versions 8.0 update_1 Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:update_1a:*:*:*:*:*:* Versions 8.0 update_1a Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:update_1c:*:*:*:*:*:* Versions 8.0 update_1c Vulnerable ·VMware
- cpe:2.3:o:vmware:esxi:8.0:update_1d:*:*:*:*:*:* Versions 8.0 update_1d Vulnerable ·VMware
Remediation
- Fix · CNA VMware ESXi Fixed in ESXi80U3-24022510
Timeline
- 2024-07-30 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2024-37085
- 2026-10-03 Alias added: GHSA-485m-923f-95wx
References
More VMware Cloud Foundation vulnerabilities
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2022-07131 Code injection in VMware Workspace ONE Access and Identity Manager KEVCVSS 3.1CRITICAL 9.8
- TI-2021-05049 Path traversal in VMware vCenter Server, VMware Cloud Foundation KEVCVSS 3.1CRITICAL 9.8
- TI-2021-05029 Improper input validation in VMware vCenter Server and VMware Cloud Foundation KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-37085 · CVE Program
- CVE-2024-37085 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-485m-923f-95wx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences