OpenCTI May Bypass Introspection Restriction
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
OpenCTI is an open source platform allowing organizations to manage their cyber threat intelligence knowledge and observables. Prior to version 6.1.9, the regex validation used to prevent Introspection queries can be bypassed by removing the extra whitespace, carriage return, and line feed characters from the query. GraphQL Queries in OpenCTI can be validated using the `secureIntrospectionPlugin`. The regex check in the plkugin can be bypassed by removing the carriage return and line feed characters (`\r\n`). Running a curl command against a local instance of OpenCTI will result in a limited error message. By running the same Introspection query without the `\r\n` characters, the unauthenticated user is able to successfully run a full Introspection query. Bypassing this restriction allows the attacker to gather a wealth of information about the GraphQL endpoint functionality that can be used to perform actions and/or read data without authorization. These queries can also be weaponized to conduct a Denial of Service (DoS) attack if sent repeatedly. Users should upgrade to version 6.1.9 to receive a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenCTI-Platform | opencti | before 6.1.9 | 6.1.9 | Patch available | CNA |
| — | pycti (PyPI) | before 6.1.9 | 6.1.9 | Patch available | GHSA-4mvw-j8r9-xcgc |
- opencti VendorOpenCTI-Platform Affected before 6.1.9 Fixed in 6.1.9 Patch available CNA
- pycti (PyPI) Vendor— Affected before 6.1.9 Fixed in 6.1.9 Patch available GHSA-4mvw-j8r9-xcgc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:citeum:opencti:*:*:*:*:*:*:*:* | before 6.1.9 | Vulnerable | OpenCTI-Platform |
- cpe:2.3:a:citeum:opencti:*:*:*:*:*:*:*:* Versions before 6.1.9 Vulnerable ·OpenCTI-Platform
Remediation
- Fix · CNA opencti (OpenCTI-Platform) Fixed in 6.1.9
- Fix · GHSA-4mvw-j8r9-xcgc pycti (PyPI) Fixed in 6.1.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-37155
- 2026-10-03 Alias added: GHSA-4mvw-j8r9-xcgc
References
Advisory 2
More OpenCTI-Platform Opencti vulnerabilities
- TI-2024-30453 OpenCTI's lack of Rate Limit lead to OTP brute forcing CVSS 3.1HIGH 8.1
- TI-2020-19176 OpenCTI 3.3.1 - Directory Traversal CVSS 4.0HIGH 7.1
- TI-2026-22303 OpenCTI privilege escalation and unauthenticated access via default admin account CVSS 3.1CRITICAL 9.8
- TI-2020-19179 OpenCTI 3.3.1 - Cross Site Scripting CVSS 4.0MEDIUM 5.1
- TI-2024-30771 OpenCTI leaks support information due to inadequate access control CVSS 3.1MEDIUM 4.3
- TI-2026-28835 OpenCTI affected by RCE via notifier template CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-37155 · CVE Program
- CVE-2024-37155 · NVD
- FIRST EPSS
- GHSA-4mvw-j8r9-xcgc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences