Elasticsearch StackOverflow vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-122 and the CVSS impact.
Summary
A flaw was discovered in Elasticsearch, affecting document ingestion when an index template contains a dynamic field mapping of “passthrough” type. Under certain circumstances, ingesting documents in this index would cause a StackOverflow exception to be thrown and ultimately lead to a Denial of Service. Note that passthrough fields is an experimental feature.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | 8.13.1 – 8.13.4 | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | 8.13.1 to before 8.14.0 | 8.14.0 | Patch available | GHSA-4q22-422g-m4pj |
- Elasticsearch VendorElastic Affected 8.13.1 – 8.13.4 Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 8.13.1 to before 8.14.0 Fixed in 8.14.0 Patch available GHSA-4q22-422g-m4pj
Remediation
- Fix · GHSA-4q22-422g-m4pj org.elasticsearch:elasticsearch (Maven) Fixed in 8.14.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Logging Subsystem for Red Hat OpenShift
- Red Hat OpenStack Platform 16.1
- Red Hat OpenStack Platform 16.2
- Red Hat Quay 3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-37280
- 2026-10-03 Alias added: GHSA-4q22-422g-m4pj
References
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-37280 · CVE Program
- CVE-2024-37280 · NVD
- FIRST EPSS
- GHSA-4q22-422g-m4pj · GitHub Advisory Database · CC BY 4.0
- CVE-2024-37280 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences