Cross-site request forgery in Sola Plugins WP Tweet Walls
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
A cross-site request forgery vulnerability exists in WP Tweet Walls versions prior to 1.0.4. If this vulnerability is exploited, an attacker allows a user who logs in to the WordPress site where the affected plugin is enabled to access a malicious page. As a result, the user may perform unintended operations on the WordPress site.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sola Plugins | WP Tweet Walls | before 1.0.4 | 1.0.4 | Patch available | CNA |
- WP Tweet Walls VendorSola Plugins Affected before 1.0.4 Fixed in 1.0.4 Patch available CNA
Remediation
- Fix · CNA WP Tweet Walls (Sola Plugins) Fixed in 1.0.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38344
- 2026-10-03 Alias added: GHSA-jvmf-76g5-h4gv
More Sola Plugins vulnerabilities
- TI-2021-13648 Nifty Newsletters <= 4.0.23 - Cross-Site Request Forgery to Stored Cross-Site Scripting CVSS 3.1HIGH 8.8
- TI-2024-25606 Cross-site request forgery in Sola Testimonials CVSS 3.1HIGH 8.1
- TI-2023-11241 WordPress Sola Support Ticket <= 3.17 - Arbitrary Content Deletion Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-08477 Super Testimonials <= 3.0.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via alignment Parameter CVSS 3.1MEDIUM 6.4
- TI-2016-09050 The sola-support-tickets plugin before 3.13 for WordPress has incorrect access control for /wp-admin with resultant XSS. CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-38344 · CVE Program
- CVE-2024-38344 · NVD
- FIRST EPSS
- GHSA-jvmf-76g5-h4gv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences