Read the docs
TI-2024-25610 Aliases CVE-2024-38351GHSA-m93w-4fxv-r35v

Password auth and OAuth2 unverified email linking

Priority LOW 24CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

Pocketbase is an open source web backend written in go. In affected versions a malicious user may be able to compromise other user accounts. In order to be exploited users must have both OAuth2 and Password auth methods enabled. A possible attack scenario could be: 1. a malicious actor register with the targeted user's email (it is unverified), 2. at some later point in time the targeted user stumble on your app and decides to sign-up with OAuth2 (_this step could be also initiated by the attacker by sending an invite email to the targeted user_), 3. on successful OAuth2 auth we search for an existing PocketBase user matching with the OAuth2 user's email and associate them, 4. because we haven't changed the password of the existing PocketBase user during the linking, the malicious actor has access to the targeted user account and will be able to login with the initially created email/password. To prevent this for happening we now reset the password for this specific case if the previously created user wasn't verified (an exception to this is if the linking is explicit/manual, aka. when you send `Authorization:TOKEN` with the OAuth2 auth call). Additionally to warn existing users we now send an email alert in case the user has logged in with password but has at least one OAuth2 account linked. The flow will be further improved with ongoing refactoring and we will start sending emails for "unrecognized device" logins (OTP and MFA is already implemented and will be available with the next v0.23.0 release in the near future). For the time being users are advised to update to version 0.22.14. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00319 25th percentileScored 2026-11-07
Fix Fixed pocketbase (pocketbase): 0.22.14github.com/pocketbase/pocketbase (Go): 0.22.14

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
pocketbasepocketbasebefore 0.22.140.22.14Patch availableCNA
—github.com/pocketbase/pocketbase (Go)before 0.22.140.22.14Patch availableGHSA-m93w-4fxv-r35v
  • pocketbase Vendorpocketbase Affected before 0.22.14 Fixed in 0.22.14 Patch available CNA
  • github.com/pocketbase/pocketbase (Go) Vendor— Affected before 0.22.14 Fixed in 0.22.14 Patch available GHSA-m93w-4fxv-r35v

Remediation

  • Fix · CNA pocketbase (pocketbase) Fixed in 0.22.14
  • Fix · GHSA-m93w-4fxv-r35v github.com/pocketbase/pocketbase (Go) Fixed in 0.22.14 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-38351
  2. 2026-10-03 Alias added: GHSA-m93w-4fxv-r35v

References

  • TI-2026-56822 Pocketbase: Unhandled panic in worker goroutines CVSS 4.0HIGH 8.7
  • TI-2026-32146 Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade CVSS 4.0MEDIUM 6.1

Sources