Pocketbase: Unhandled panic in worker goroutines
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.
Summary
Pocketbase is an open source web backend written in go. Prior to 0.22.48 and 0.39.7, PocketBase's panic-recovery middleware covers regular request handling but not internal child and worker goroutines. A panic in one of these internal goroutines can escape recovery and terminate the server process, causing a denial of service. The remediation introduces routine.SafeWrap to convert recovered panics into regular errors and applies it to the affected internal worker functions. This issue is fixed in versions 0.22.48 and 0.39.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pocketbase | pocketbase | before 0.22.48; 0.23.0 to before 0.39.7 | 0.22.48, 0.39.7 | Patch available | CNA |
| — | github.com/pocketbase/pocketbase (Go) | before 0.22.48 | 0.22.48 | Patch available | GHSA-84vh-m24q-wjjx |
| — | github.com/pocketbase/pocketbase (Go) | 0.23.0 to before 0.39.7 | 0.39.7 | Patch available | GHSA-84vh-m24q-wjjx |
- pocketbase Vendorpocketbase Affected before 0.22.48; 0.23.0 to before 0.39.7 Fixed in 0.22.48, 0.39.7 Patch available CNA
- github.com/pocketbase/pocketbase (Go) Vendor— Affected before 0.22.48 Fixed in 0.22.48 Patch available GHSA-84vh-m24q-wjjx
- github.com/pocketbase/pocketbase (Go) Vendor— Affected 0.23.0 to before 0.39.7 Fixed in 0.39.7 Patch available GHSA-84vh-m24q-wjjx
Remediation
- Fix · CNA pocketbase (pocketbase) Fixed in 0.22.48, 0.39.7
- Fix · GHSA-84vh-m24q-wjjx github.com/pocketbase/pocketbase (Go) Fixed in 0.22.48 Advisory →
- Fix · GHSA-84vh-m24q-wjjx github.com/pocketbase/pocketbase (Go) Fixed in 0.39.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-82410
- 2026-10-03 Alias added: GHSA-84vh-m24q-wjjx
References
Other 7
- https://github.com/pocketbase/pocketbase/security/advisories/GHSA-84vh-m24q-wjjx
- https://github.com/pocketbase/pocketbase/commit/30b4184305904fae0d1b78216c4e3cc34700b220
- https://github.com/pocketbase/pocketbase/commit/f1618ee59b6d1c0308bb474c827a2b1f24b12a95
- https://github.com/pocketbase/pocketbase/discussions/7762
- https://github.com/pocketbase/pocketbase/releases/tag/v0.22.48
- https://github.com/pocketbase/pocketbase/releases/tag/v0.39.7
- https://github.com/pocketbase/pocketbase
More pocketbase vulnerabilities
- TI-2026-32146 Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade CVSS 4.0MEDIUM 6.1
- TI-2024-25610 Password auth and OAuth2 unverified email linking CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-82410 · CVE Program
- CVE-2026-82410 · NVD
- FIRST EPSS
- GHSA-84vh-m24q-wjjx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences