Undici vulnerable to data leak when using response.arrayBuffer()
Priority MEDIUM 44CWE-201Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-201.
Summary
Undici is an HTTP/1.1 client, written from scratch for Node.js. Depending on network and process conditions of a `fetch()` request, `response.arrayBuffer()` might include portion of memory from the Node.js process. This has been patched in v6.19.2.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00467 40th percentileScored 2026-11-07
Fix Fixed undici (nodejs): 6.19.2undici (npm): 6.19.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | undici | 6.14.0 to before 6.19.2 | 6.19.2 | Patch available | CNA |
| — | undici (npm) | 6.14.0 to before 6.19.2 | 6.19.2 | Patch available | GHSA-3g92-w8c5-73pq |
- undici VendorNodeJS Affected 6.14.0 to before 6.19.2 Fixed in 6.19.2 Patch available CNA
- undici (npm) Vendor— Affected 6.14.0 to before 6.19.2 Fixed in 6.19.2 Patch available GHSA-3g92-w8c5-73pq
Remediation
- Fix · CNA undici (nodejs) Fixed in 6.19.2
- Fix · GHSA-3g92-w8c5-73pq undici (npm) Fixed in 6.19.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38372
- 2026-10-03 Alias added: GHSA-3g92-w8c5-73pq
References
Other 6
- https://github.com/nodejs/undici/security/advisories/GHSA-3g92-w8c5-73pq
- https://github.com/nodejs/undici/issues/3328
- https://github.com/nodejs/undici/issues/3337
- https://github.com/nodejs/undici/pull/3338
- https://github.com/nodejs/undici/commit/f979ec3204ca489abf30e7d20e9fee9ea7711d36
- https://github.com/nodejs/undici
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2024-38372 · CVE Program
- CVE-2024-38372 · NVD
- FIRST EPSS
- GHSA-3g92-w8c5-73pq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences