Read the docs
TI-2024-26267 Aliases CVE-2024-39311GHSA-8fm5-gg2f-f66q

Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction

Priority MEDIUM 43CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Publify is a self hosted Web publishing platform on Rails. Prior to version 10.0.1 of Publify, corresponding to versions prior to 10.0.2 of the `publify_core` rubygem, publisher on a `publify` application is able to perform a cross-site scripting (XSS) attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. A publisher may attempt to use this vulnerability to escalate their privileges and become an administrator. Version 10.0.1 of Publify and version 10.0.2 of the `publify_core` rubygem fix the issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00271 19th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed publify (publify): 10.0.1publify_core (RubyGems): 10.0.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
publifypublifybefore 10.0.110.0.1Patch availableCNA
—publify_core (RubyGems)before 10.0.210.0.2Patch availableGHSA-8fm5-gg2f-f66q
  • publify Vendorpublify Affected before 10.0.1 Fixed in 10.0.1 Patch available CNA
  • publify_core (RubyGems) Vendor— Affected before 10.0.2 Fixed in 10.0.2 Patch available GHSA-8fm5-gg2f-f66q

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:publify:publify:*:*:*:*:*:*:*:*before 10.0.1Vulnerablepublify
cpe:2.3:a:publify:publify_core:*:*:*:*:*:ruby:*:*before 10.0.2Vulnerablepublify
  • cpe:2.3:a:publify:publify:*:*:*:*:*:*:*:* Versions before 10.0.1 Vulnerable ·publify
  • cpe:2.3:a:publify:publify_core:*:*:*:*:*:ruby:*:* Versions before 10.0.2 Vulnerable ·publify

Remediation

  • Fix · CNA publify (publify) Fixed in 10.0.1
  • Fix · GHSA-8fm5-gg2f-f66q publify_core (RubyGems) Fixed in 10.0.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-39311
  2. 2026-10-03 Alias added: GHSA-8fm5-gg2f-f66q

References

  • TI-2014-02574 Publify before 8.0.1 is vulnerable to a Denial of Service attack CVSS 3.1HIGH 7.5

Sources