Malicious remote can create arbitrary channels
Priority LOW 24CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6 fail to properly restrict channel creation which allows a malicious remote to create arbitrary channels, when shared channels were enabled.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00283 20th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 9.10.0, 9.9.1, 9.5.7github.com/mattermost/mattermost/server/v8 (Go): 9.5.7, 9.9.1, 8.0.0-20240626164322-c758cecaf30c+3 more products
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 9.9.0; 9.5.0 – 9.5.6 | 9.10.0, 9.9.1, 9.5.7 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.5.0 to before 9.5.7 | 9.5.7 | Patch available | GHSA-vvpg-55p7-5h8w |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.9.0 to before 9.9.1 | 9.9.1 | Patch available | GHSA-vvpg-55p7-5h8w |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20240626164322-c758cecaf30c | 8.0.0-20240626164322-c758cecaf30c | Patch available | GHSA-vvpg-55p7-5h8w |
| — | github.com/mattermost/mattermost-server (Go) | 9.9.0 to before 9.9.1 | 9.9.1 | Patch available | GHSA-vvpg-55p7-5h8w |
| — | github.com/mattermost/mattermost-server/v5 (Go) | before 5.3.2-0.20240626164322-c758cecaf30c | 5.3.2-0.20240626164322-c758cecaf30c | Patch available | GHSA-vvpg-55p7-5h8w |
| — | github.com/mattermost/mattermost-server/v6 (Go) | before 6.0.0-20240626164322-c758cecaf30c | 6.0.0-20240626164322-c758cecaf30c | Patch available | GHSA-vvpg-55p7-5h8w |
| — | github.com/mattermost/mattermost-server (Go) | 9.5.0 to before 9.5.7 | 9.5.7 | Patch available | GHSA-vvpg-55p7-5h8w |
- Mattermost VendorMattermost Affected 9.9.0; 9.5.0 – 9.5.6 Fixed in 9.10.0, 9.9.1, 9.5.7 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.5.0 to before 9.5.7 Fixed in 9.5.7 Patch available GHSA-vvpg-55p7-5h8w
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.9.0 to before 9.9.1 Fixed in 9.9.1 Patch available GHSA-vvpg-55p7-5h8w
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20240626164322-c758cecaf30c Fixed in 8.0.0-20240626164322-c758cecaf30c Patch available GHSA-vvpg-55p7-5h8w
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 9.9.0 to before 9.9.1 Fixed in 9.9.1 Patch available GHSA-vvpg-55p7-5h8w
- github.com/mattermost/mattermost-server/v5 (Go) Vendor— Affected before 5.3.2-0.20240626164322-c758cecaf30c Fixed in 5.3.2-0.20240626164322-c758cecaf30c Patch available GHSA-vvpg-55p7-5h8w
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected before 6.0.0-20240626164322-c758cecaf30c Fixed in 6.0.0-20240626164322-c758cecaf30c Patch available GHSA-vvpg-55p7-5h8w
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 9.5.0 to before 9.5.7 Fixed in 9.5.7 Patch available GHSA-vvpg-55p7-5h8w
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.5.0 to before 9.5.7 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:9.9.0:*:*:*:*:*:*:* | 9.9.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.5.0 to before 9.5.7 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:9.9.0:*:*:*:*:*:*:* Versions 9.9.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.10.0, 9.9.1, 9.5.7
- Fix · GHSA-vvpg-55p7-5h8w github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.5.7 Advisory →
- Fix · GHSA-vvpg-55p7-5h8w github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.9.1 Advisory →
- Fix · GHSA-vvpg-55p7-5h8w github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20240626164322-c758cecaf30c Advisory →
- Fix · GHSA-vvpg-55p7-5h8w github.com/mattermost/mattermost-server (Go) Fixed in 9.9.1 Advisory →
- Fix · GHSA-vvpg-55p7-5h8w github.com/mattermost/mattermost-server/v5 (Go) Fixed in 5.3.2-0.20240626164322-c758cecaf30c Advisory →
- Fix · GHSA-vvpg-55p7-5h8w github.com/mattermost/mattermost-server/v6 (Go) Fixed in 6.0.0-20240626164322-c758cecaf30c Advisory →
- Fix · GHSA-vvpg-55p7-5h8w github.com/mattermost/mattermost-server (Go) Fixed in 9.5.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-39837
- 2026-10-03 Alias added: GHSA-vvpg-55p7-5h8w
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-39837 · CVE Program
- CVE-2024-39837 · NVD
- FIRST EPSS
- GHSA-vvpg-55p7-5h8w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences