Read the docs
TI-2024-27058 Aliases CVE-2024-40647GHSA-g92j-qhmh-64v2

Unintentional exposure of environment variables to subprocesses in sentry-sdk

Priority LOW 23CWE-200Published · Updated

Key facts

Attack vector
Local
Privileges required
High
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

sentry-sdk is the official Python SDK for Sentry.io. A bug in Sentry's Python SDK < 2.8.0 allows the environment variables to be passed to subprocesses despite the `env={}` setting. In Python's `subprocess` calls, all environment variables are passed to subprocesses by default. However, if you specifically do not want them to be passed to subprocesses, you may use `env` argument in `subprocess` calls. Due to the bug in Sentry SDK, with the Stdlib integration enabled (which is enabled by default), this expectation is not fulfilled, and all environment variables are being passed to subprocesses instead. The issue has been patched in pull request #3251 and is included in sentry-sdk==2.8.0. We strongly recommend upgrading to the latest SDK version. However, if it's not possible, and if passing environment variables to child processes poses a security risk for you, you can disable all default integrations.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.002 9th percentileScored 2026-11-07
Fix Fixed sentry-python (getsentry): 2.8.0sentry-sdk (PyPI): 2.8.0, 1.45.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getsentrysentry-pythonbefore 2.8.02.8.0Patch availableCNA
—sentry-sdk (PyPI)2.0.0a1 to before 2.8.02.8.0Patch availableGHSA-g92j-qhmh-64v2
—sentry-sdk (PyPI)before 1.45.11.45.1Patch availableGHSA-g92j-qhmh-64v2
  • sentry-python Vendorgetsentry Affected before 2.8.0 Fixed in 2.8.0 Patch available CNA
  • sentry-sdk (PyPI) Vendor— Affected 2.0.0a1 to before 2.8.0 Fixed in 2.8.0 Patch available GHSA-g92j-qhmh-64v2
  • sentry-sdk (PyPI) Vendor— Affected before 1.45.1 Fixed in 1.45.1 Patch available GHSA-g92j-qhmh-64v2

Remediation

  • Fix · CNA sentry-python (getsentry) Fixed in 2.8.0
  • Fix · GHSA-g92j-qhmh-64v2 sentry-sdk (PyPI) Fixed in 2.8.0 Advisory →
  • Fix · GHSA-g92j-qhmh-64v2 sentry-sdk (PyPI) Fixed in 1.45.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-40647
  2. 2026-10-03 Alias added: GHSA-g92j-qhmh-64v2

References

  • TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
  • TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
  • TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
  • TI-2025-16094 Improper authentication on SAML SSO process allows user impersonation in sentry CVSS 3.1CRITICAL 9.1
  • TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
  • TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
See all 28 →

Sources