Ampache Stored Cross-site Scripting Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Ampache, a web based audio/video streaming application and file manager, has a stored cross-site scripting (XSS) vulnerability in versions prior to 6.6.0. This vulnerability exists in the "Playlists - Democratic - Configure Democratic Playlist" feature. An attacker with Content Manager permissions can set the Name field to `<svg onload=alert(8)>`. When any administrator or user accesses the Democratic functionality, they will be affected by this stored XSS vulnerability. The attacker can exploit this vulnerability to obtain the cookies of any user or administrator who accesses the `democratic.php` file. Version 6.6.0 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ampache (ampache) Fixed in 6.6.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-41665
References
More Ampache vulnerabilities
- TI-2023-00731 SQL Injection in ampache/ampache CVSS 3.1HIGH 8.8
- TI-2022-04263 Unrestricted Upload of File with Dangerous Type in ampache/ampache CVSS 3.1HIGH 8.8
- TI-2024-32095 Cross-Site Request Forgery in ampache CVSS 3.1MEDIUM 6.5
- TI-2023-00573 Cross-site Scripting (XSS) - Reflected in ampache/ampache CVSS 3.1MEDIUM 6.1
- TI-2024-31551 Ampache vulnerable to Stored XSS via Democratic Playlist Name CVSS 3.1MEDIUM 6.1
- TI-2024-19055 Ampache Stored XSS CVSS 3.1MEDIUM 5.9
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences