HPE IceWall Agent products, Cross-Site Request Forgery (CSRF)
Priority LOW 19CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
A security vulnerability in HPE IceWall Agent products could be exploited remotely to cause a Cross-Site Request Forgery (CSRF) in the login flow.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00161 5th percentileScored 2026-11-07
Fix Fixed HPE IceWall Agent products (Hewlett Packard Enterprise): 4.0, 11, 10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hewlett Packard Enterprise | HPE IceWall Agent products | IceWall Federation Agent to before 4.0; IceWall Gen11 Enterprise Edition to before 11; IceWall SSO Agent Option to before 10 | 4.0, 11, 10 | Patch available | CNA |
- HPE IceWall Agent products VendorHewlett Packard Enterprise Affected IceWall Federation Agent to before 4.0; IceWall Gen11 Enterprise Edition to before 11; IceWall SSO Agent Option to before 10 Fixed in 4.0, 11, 10 Patch available CNA
Remediation
- Fix · CNA HPE IceWall Agent products (Hewlett Packard Enterprise) Fixed in 4.0, 11, 10
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42504
- 2026-10-03 Alias added: GHSA-269v-rmv9-mwh8
References
More Hewlett Packard Enterprise vulnerabilities
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2015-02747 Heap-based buffer overflow in Adobe Flash Player before 13.0.0.296 and 14.x through 18.x… KEVCVSS 3.1CRITICAL 9.8
- TI-2013-04219 HP ProCurve Manager (PCM) 3.20 and 4.0, PCM+ 3.20 and 4.0, Identity Driven Manager (IDM)… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2005-02634 HP OpenView Network Node Manager 6.2 through 7.50 allows remote attackers to execute… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-07113 Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before… KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2024-42504 · CVE Program
- CVE-2024-42504 · NVD
- FIRST EPSS
- GHSA-269v-rmv9-mwh8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences