Improper Access Control Vulnerability When Accessing a Maliciously Crafted Tophat Link
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
Tophat is a mobile applications testing harness. An Improper Access Control vulnerability can expose the `TOPHAT_APP_TOKEN` token stored in `~/.tophatrc` through use of a malicious Tophat URL controlled by the attacker. The vulnerability allows Tophat to send this token to the attacker's server without any checks to ensure that the server is trusted. This token can then be used to access internal build artifacts, for mobile applications, not intended to be public. The issue has been patched as of version 1.10.0. The ability to request artifacts using a Tophat API has been deprecated as this flow was inherently insecure. Systems that have implemented this kind of endpoint should cease use and invalidate the token immediately. There are no workarounds and all users should update as soon as possible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA tophat (Shopify) Fixed in 1.10.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45036
References
More remix-run vulnerabilities
- TI-2025-28449 React Router allows pre-render data spoofing on React-Router framework mode CVSS 3.1HIGH 8.2
- TI-2025-28448 React Router allows a DoS via cache poisoning by forcing SPA mode CVSS 3.1HIGH 7.5
- TI-2025-38117 React Router has Path Traversal in File Session Storage CVSS 3.1CRITICAL 9.1
- TI-2026-40200 React Router: Unauthenticated Denial of Service via Inefficient Route Matching CVSS 4.0HIGH 8.7
- TI-2025-33550 Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class CVSS 4.0HIGH 8.1
- TI-2026-26385 Ruby LSP has arbitrary code execution through branch setting CVSS 4.0HIGH 7.1
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences