Apache Solr: ConfigSets created during a backup restore command are trusted implicitly
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Insecure Default Initialization of Resource vulnerability in Apache Solr. New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized. This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization. Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Solr | 6.6.0 to before 8.11.4; 9.0.0 to before 9.7.0 | 8.11.4, 9.7.0 | Patch available | CNA |
| — | org.apache.solr:solr (Maven) | 6.6.0 to before 8.11.4 | 8.11.4 | Patch available | GHSA-h7w9-c5vx-x7j3 |
| — | org.apache.solr:solr (Maven) | 9.0.0 to before 9.7.0 | 9.7.0 | Patch available | GHSA-h7w9-c5vx-x7j3 |
- Apache Solr VendorApache Affected 6.6.0 to before 8.11.4; 9.0.0 to before 9.7.0 Fixed in 8.11.4, 9.7.0 Patch available CNA
- org.apache.solr:solr (Maven) Vendor— Affected 6.6.0 to before 8.11.4 Fixed in 8.11.4 Patch available GHSA-h7w9-c5vx-x7j3
- org.apache.solr:solr (Maven) Vendor— Affected 9.0.0 to before 9.7.0 Fixed in 9.7.0 Patch available GHSA-h7w9-c5vx-x7j3
Remediation
- Fix · CNA Apache Solr (Apache Software Foundation) Fixed in 8.11.4, 9.7.0
- Fix · GHSA-h7w9-c5vx-x7j3 org.apache.solr:solr (Maven) Fixed in 8.11.4 Advisory →
- Fix · GHSA-h7w9-c5vx-x7j3 org.apache.solr:solr (Maven) Fixed in 9.7.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Solr 8.11.4, 9.7.0
2 records Highest priority Priority CRITICAL 1 CRITICAL, 1 LOW
Other records, highest priority first
- TI-2024-30303 Apache Solr: Authentication bypass possible using a fake URL Path endingPriority CRITICAL 92
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45217
- 2026-10-03 Alias added: GHSA-h7w9-c5vx-x7j3
References
Advisory 2
More Apache Solr vulnerabilities
- TI-2024-30303 Apache Solr: Authentication bypass possible using a fake URL Path ending CVSS 3.1CRITICAL 9.8
- TI-2019-13101 Injection in Apache Solr KEVCVSS 3.1HIGH 7.5
- TI-2019-00170 Code injection in Apache Solr KEVCVSS 3.1HIGH 7.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2021-09240 SSRF vulnerability with the Replication handler CVSS 3.1CRITICAL 9.8
- TI-2017-09354 XML external entity injection in Apache Solr before 7.1 with Apache Lucene before 7.1 CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-45217 · CVE Program
- CVE-2024-45217 · NVD
- FIRST EPSS
- GHSA-h7w9-c5vx-x7j3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences