Cross-site request forgery in Sayful Islam Carousel Slider
Priority LOW 20CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
WordPress plugin "Carousel Slider" provided by Sayful Islam contains a cross-site request forgery vulnerability on Carousel image selection feature. While logged in to the WordPress site with Carousel Slider plugin enabled, accessing a crafted page may cause a user to alter the contents of the WordPress site.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00272 19th percentileScored 2026-11-07
Fix Fixed Carousel Slider (Sayful Islam): 2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sayful Islam | Carousel Slider | before 2.0 | 2.0 | Patch available | CNA |
- Carousel Slider VendorSayful Islam Affected before 2.0 Fixed in 2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:majeedraza:carousel_slider:*:*:*:*:*:wordpress:*:* | before 2.0 | Vulnerable | Majeed Raza |
- cpe:2.3:a:majeedraza:carousel_slider:*:*:*:*:*:wordpress:*:* Versions before 2.0 Vulnerable ·Majeed Raza
Remediation
- Fix · CNA Carousel Slider (Sayful Islam) Fixed in 2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45269
- 2026-10-03 Alias added: GHSA-7cvv-34h5-xg2q
References
More Sayful Islam vulnerabilities
- TI-2024-03939 WordPress Filterable Portfolio plugin <= 1.6.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
- TI-2025-35846 WordPress Upcoming Events Lists Plugin <= 1.4.0 - Insecure Direct Object References (IDOR) Vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-45269 · CVE Program
- CVE-2024-45269 · NVD
- FIRST EPSS
- GHSA-7cvv-34h5-xg2q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences