Improper authorization on deletion of user issue alert notifications in sentry
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getsentry | sentry | 23.9.0 to before 24.9.0 | 24.9.0 | Patch available | CNA |
| — | sentry (PyPI) | 23.9.0 to before 24.9.0 | 24.9.0 | Patch available | GHSA-54m3-95j9-v89j |
- sentry Vendorgetsentry Affected 23.9.0 to before 24.9.0 Fixed in 24.9.0 Patch available CNA
- sentry (PyPI) Vendor— Affected 23.9.0 to before 24.9.0 Fixed in 24.9.0 Patch available GHSA-54m3-95j9-v89j
Remediation
- Fix · CNA sentry (getsentry) Fixed in 24.9.0
- Fix · GHSA-54m3-95j9-v89j sentry (PyPI) Fixed in 24.9.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45605
- 2026-10-03 Alias added: GHSA-54m3-95j9-v89j
References
Advisory 2
More getsentry vulnerabilities
- TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
- TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
- TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
- TI-2025-16094 Improper authentication on SAML SSO process allows user impersonation in sentry CVSS 3.1CRITICAL 9.1
- TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
- TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-45605 · CVE Program
- CVE-2024-45605 · NVD
- FIRST EPSS
- GHSA-54m3-95j9-v89j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences