Missing authentication in NetAlertX
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-306.
Summary
NetAlertX 23.01.14 through 24.x before 24.10.12 allows unauthenticated command injection via settings update because function=savesettings lacks an authentication requirement, as exploited in the wild in May 2025. This is related to settings.php and util.php.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA NetAlertX (NetAlertX) Fixed in 24.10.12
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
NetAlertX 24.10.12
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2024-32490 Path traversal in NetAlertXPriority HIGH 80
Timeline
- 2026-10-02 Threatist record created from CVE-2024-46506
- 2026-10-03 Alias added: GHSA-3qp4-7wm4-9hhr
References
More Netalertx vulnerabilities
- TI-2025-31090 NetAlertX has Password Bypass Vulnerability due to Loose Comparison in PHP CVSS 3.1CRITICAL 9.4
- TI-2025-23511 NetAlertX Vulnerable to Authentication Bypass CVSS 3.1CRITICAL 10.0
- TI-2024-32490 Path traversal in NetAlertX CVSS 3.1HIGH 8.6
Sources
- CVE-2024-46506 · CVE Program
- CVE-2024-46506 · NVD
- FIRST EPSS
- GHSA-3qp4-7wm4-9hhr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences