NetAlertX has Password Bypass Vulnerability due to Loose Comparison in PHP
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
NetAlertX is a network, presence scanner, and alert framework. Prior to version 25.6.7, a vulnerability in the authentication logic allows users to bypass password verification using SHA-256 magic hashes, due to loose comparison in PHP. In vulnerable versions of the application, a password comparison is performed using the `==` operator at line 40 in front/index.php. This introduces a security issue where specially crafted "magic hash" values that evaluate to true in a loose comparison can bypass authentication. Because of the use of `==` instead of the strict `===`, different strings that begin with 0e and are followed by only digits can be interpreted as scientific notation (i.e., zero) and treated as equal. This issue falls under the Login Bypass vulnerability class. Users with certain "weird" passwords that produce magic hashes are particularly affected. Services relying on this logic are at risk of unauthorized access. Version 25.6.7 fixes the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jokob-sk | NetAlertX | before 25.6.7 | 25.6.7 | Patch available | CNA |
- NetAlertX Vendorjokob-sk Affected before 25.6.7 Fixed in 25.6.7 Patch available CNA
Remediation
- Fix · CNA NetAlertX (jokob-sk) Fixed in 25.6.7
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48952
More Netalertx vulnerabilities
- TI-2024-31001 Missing authentication in NetAlertX CVSS 3.1CRITICAL 10.0
- TI-2025-23511 NetAlertX Vulnerable to Authentication Bypass CVSS 3.1CRITICAL 10.0
- TI-2024-32490 Path traversal in NetAlertX CVSS 3.1HIGH 8.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences