Apache Roller: Weakness in CSRF protection allows privilege escalation
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
Cross-site Resource Forgery (CSRF), Privilege escalation vulnerability in Apache Roller. On multi-blog/user Roller websites, by default weblog owners are trusted to publish arbitrary weblog content and this combined with a deficiency in Roller's CSRF protections allowed an escalation of privileges attack. This issue affects Apache Roller before 6.1.4. Roller users who run multi-blog/user Roller websites are recommended to upgrade to version 6.1.4, which fixes the issue. Roller 6.1.4 release announcement: https://lists.apache.org/thread/3c3f6rwqptyw6wdc95654fq5vlosqdpw
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Apache Roller (Apache Software Foundation) Fixed in 6.1.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-46911
- 2026-10-03 Alias added: GHSA-m3gr-45jc-g2rp
References
More Apache Roller vulnerabilities
- TI-2013-03684 Certain getText methods in the ActionSupport controller in Apache Roller before 5.0.2… CVSS 2.0MEDIUM 6.8
- TI-2014-00028 The XML-RPC protocol support in Apache Roller before 5.0.3 allows attackers to conduct… CVSS 3.0CRITICAL 9.8
- TI-2018-12297 Server-side request forgery in Apache Roller CVSS 3.0CRITICAL 9.8
- TI-2021-12966 regex injection leading to DoS CVSS 3.1HIGH 7.5
- TI-2015-00218 The weblog page template in Apache Roller 5.1 through 5.1.1 allows remote authenticated… CVSS 3.0HIGH 7.2
- TI-2019-00207 Cross-site scripting in Apache Roller CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-46911 · CVE Program
- CVE-2024-46911 · NVD
- FIRST EPSS
- GHSA-m3gr-45jc-g2rp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences