Priority HIGH 70
Certain getText methods in the ActionSupport controller in Apache Roller before 5.0.2 allow remote attackers to execute arbitrary OGNL expressions via the first or second parameter, as demonstrated by the pageTitle param…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.81068 · Published 2013-12-07 · No fix listed CWE-94
Priority MEDIUM 59
The XML-RPC protocol support in Apache Roller before 5.0.3 allows attackers to conduct XML External Entity (XXE) attacks via unspecified vectors.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.16867 · Published 2017-10-09 · No fix listed CWE-611
Priority MEDIUM 49
Server-side Request Forgery (SSRF) and File Enumeration vulnerability in Apache Roller 5.2.1, 5.2.0 and earlier unsupported versions relies on Java SAX Parser to implement its XML-RPC interface and by default that parser…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04124 · Published 2019-05-28 · No fix listed CWE-918
Priority LOW 39
User controlled `request.getHeader("Referer")`, `request.getRequestURL()` and `request.getQueryString()` are used to build and run a regex expression.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.03298 · Published 2021-08-18 · Fixed in 6.0.2 CWE-400
Priority LOW 39
The weblog page template in Apache Roller 5.1 through 5.1.1 allows remote authenticated users with admin privileges for a weblog to execute arbitrary Java code via crafted Velocity Text Language (aka VTL).
CVSS 3.0HIGH 7.2· Network · High privileges · No interaction · EPSS 0.04587 · Published 2017-07-14 · No fix listed CWE-94
Priority LOW 33
A Reflected Cross-site Scripting (XSS) vulnerability exists in Apache Roller.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.03445 · Published 2019-07-15 · No fix listed CWE-79
Priority LOW 33
Multiple cross-site request forgery (CSRF) vulnerabilities in the admin/editor console in Apache Roller before 5.0.1 allow remote attackers to hijack the authentication of admins or editors by leveraging the HTTP POST fu…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.01574 · Published 2012-06-26 · No fix listed CWE-352
Priority LOW 28
Cross-site scripting (XSS) vulnerability in Apache Roller 2.3, 3.0, 3.1, and 4.0 allows remote attackers to inject arbitrary web script or HTML via the q parameter in a search action.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.04989 · Published 2009-07-30 · No fix listed CWE-79
Priority LOW 27
Insufficient input validation and sanitation in Weblog Category name, Website About and File Upload features in all versions of Apache Roller on all platforms allows an authenticated user to perform an XSS attack.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01172 · Published 2023-08-06 · Fixed in 6.1.2 CWE-79
Priority LOW 26
Insufficient input validation and sanitation in Profile name & screenname, Bookmark name & description and blogroll name features in all versions of Apache Roller on all platforms allows an authenticated user to perform…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00752 · Published 2024-07-26 · Fixed in 6.1.3 CWE-20
Priority LOW 25
Multiple cross-site scripting (XSS) vulnerabilities in Apache Roller before 5.0.2 allow remote attackers to inject arbitrary web script or HTML via vectors related to the search results in the (1) RSS and (2) Atom feed t…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.02969 · Published 2013-12-07 · No fix listed CWE-79
Priority LOW 22
A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes.
CVSS 4.0LOW 2.1· Network · High privileges · No interaction · EPSS 0.01158 · Published 2025-04-14 · Fixed in 6.1.5 CWE-613
Priority LOW 22
Cross-site Resource Forgery (CSRF), Privilege escalation vulnerability in Apache Roller.
CVSS 3.1MEDIUM 4.7· Network · High privileges · No interaction · EPSS 0.00447 · Published 2024-10-14 · Fixed in 6.1.4 CWE-352
Priority LOW 22
Multiple cross-site scripting (XSS) vulnerabilities in Apache Roller before 5.0.1 allow remote authenticated users to inject arbitrary web script or HTML by leveraging the blogger role.
CVSS 2.0LOW 3.5· Network · Low privileges · Interaction — · EPSS 0.02487 · Published 2012-06-26 · No fix listed CWE-79