Plenti arbitrary file write vulnerability
Priority HIGH 80CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Plenti, a static site generator, has an arbitrary file write vulnerability in versions prior to 0.7.2. The `/postLocal` endpoint is vulnerable to an arbitrary file write vulnerability when a plenti user serves their website. This issue may lead to Remote Code Execution. Version 0.7.2 fixes the vulnerability.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02705 86th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed plenti (plentico): 0.7.2github.com/plentico/plenti (Go): 0.7.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| plentico | plenti | before 0.7.2 | 0.7.2 | Patch available | CNA |
| — | github.com/plentico/plenti (Go) | before 0.7.2 | 0.7.2 | Patch available | GHSA-2p96-p7qh-4rgr |
- plenti Vendorplentico Affected before 0.7.2 Fixed in 0.7.2 Patch available CNA
- github.com/plentico/plenti (Go) Vendor— Affected before 0.7.2 Fixed in 0.7.2 Patch available GHSA-2p96-p7qh-4rgr
Remediation
- Fix · CNA plenti (plentico) Fixed in 0.7.2
- Fix · GHSA-2p96-p7qh-4rgr github.com/plentico/plenti (Go) Fixed in 0.7.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-49380
- 2026-10-03 Alias added: GHSA-2p96-p7qh-4rgr
References
Advisory 2
More Plenti vulnerabilities
- TI-2025-19274 Plenti <= 0.7.16 is vulnerable to code execution. CVSS 3.1HIGH 8.8
- TI-2024-32966 Plenti arbitrary file deletion vulnerability CVSS 4.0HIGH 7.7
Sources
- CVE-2024-49380 · CVE Program
- CVE-2024-49380 · NVD
- FIRST EPSS
- GHSA-2p96-p7qh-4rgr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences