Read the docs
TI-2025-19274 Aliases CVE-2025-26260GHSA-mj4v-hp69-27x5

Plenti <= 0.7.16 is vulnerable to code execution.

Priority HIGH 73CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Plenti <= 0.7.16 is vulnerable to code execution. Users uploading '.svelte' files with the /postLocal endpoint can define the file name as javascript codes. The server executes the uploaded file name in host, and cause code execution.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0076 55th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed github.com/plentico/plenti (Go): 0.7.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—github.com/plentico/plenti (Go)before 0.7.170.7.17Patch availableGHSA-mj4v-hp69-27x5
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • github.com/plentico/plenti (Go) Vendor— Affected before 0.7.17 Fixed in 0.7.17 Patch available GHSA-mj4v-hp69-27x5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:plenti:plenti:*:*:*:*:*:*:*:*before 0.7.17VulnerablePlenti
  • cpe:2.3:a:plenti:plenti:*:*:*:*:*:*:*:* Versions before 0.7.17 Vulnerable ·Plenti

Remediation

  • Fix · GHSA-mj4v-hp69-27x5 github.com/plentico/plenti (Go) Fixed in 0.7.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-26260
  2. 2026-10-03 Alias added: GHSA-mj4v-hp69-27x5

References

  • TI-2024-32965 Plenti arbitrary file write vulnerability CVSS 4.0HIGH 8.9
  • TI-2024-32966 Plenti arbitrary file deletion vulnerability CVSS 4.0HIGH 7.7

Sources