Security::login does not take into account custom user_checker in symfony/security-bundle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
symfony/security-bundle is a module for the Symphony PHP framework which provides a tight integration of the Security component into the Symfony full-stack framework. The custom `user_checker` defined on a firewall is not called when Login Programmaticaly with the `Security::login` method, leading to unwanted login. As of versions 6.4.10, 7.0.10 and 7.1.3 the `Security::login` method now ensure to call the configured `user_checker`. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 6.2.0 to before 6.4.10; 7.0.0 to before 7.0.10; 7.1.0 to before 7.1.3 | 6.4.10, 7.0.10, 7.1.3 | Patch available | CNA |
| — | symfony/security-bundle (Packagist) | 6.2.0 to before 6.4.10 | 6.4.10 | Patch available | GHSA-jxgr-3v7q-3w9v |
| — | symfony/security-bundle (Packagist) | 7.0.0 to before 7.0.10 | 7.0.10 | Patch available | GHSA-jxgr-3v7q-3w9v |
| — | symfony/security-bundle (Packagist) | 7.1.0 to before 7.1.3 | 7.1.3 | Patch available | GHSA-jxgr-3v7q-3w9v |
| — | symfony/symfony (Packagist) | 6.2.0 to before 6.4.10 | 6.4.10 | Patch available | GHSA-jxgr-3v7q-3w9v |
| — | symfony/symfony (Packagist) | 7.0.0 to before 7.0.10 | 7.0.10 | Patch available | GHSA-jxgr-3v7q-3w9v |
| — | symfony/symfony (Packagist) | 7.1.0 to before 7.1.3 | 7.1.3 | Patch available | GHSA-jxgr-3v7q-3w9v |
- symfony Vendorsymfony Affected 6.2.0 to before 6.4.10; 7.0.0 to before 7.0.10; 7.1.0 to before 7.1.3 Fixed in 6.4.10, 7.0.10, 7.1.3 Patch available CNA
- symfony/security-bundle (Packagist) Vendor— Affected 6.2.0 to before 6.4.10 Fixed in 6.4.10 Patch available GHSA-jxgr-3v7q-3w9v
- symfony/security-bundle (Packagist) Vendor— Affected 7.0.0 to before 7.0.10 Fixed in 7.0.10 Patch available GHSA-jxgr-3v7q-3w9v
- symfony/security-bundle (Packagist) Vendor— Affected 7.1.0 to before 7.1.3 Fixed in 7.1.3 Patch available GHSA-jxgr-3v7q-3w9v
- symfony/symfony (Packagist) Vendor— Affected 6.2.0 to before 6.4.10 Fixed in 6.4.10 Patch available GHSA-jxgr-3v7q-3w9v
- symfony/symfony (Packagist) Vendor— Affected 7.0.0 to before 7.0.10 Fixed in 7.0.10 Patch available GHSA-jxgr-3v7q-3w9v
- symfony/symfony (Packagist) Vendor— Affected 7.1.0 to before 7.1.3 Fixed in 7.1.3 Patch available GHSA-jxgr-3v7q-3w9v
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | — | — | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions — — ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 6.4.10, 7.0.10, 7.1.3
- Fix · GHSA-jxgr-3v7q-3w9v symfony/security-bundle (Packagist) Fixed in 6.4.10 Advisory →
- Fix · GHSA-jxgr-3v7q-3w9v symfony/security-bundle (Packagist) Fixed in 7.0.10 Advisory →
- Fix · GHSA-jxgr-3v7q-3w9v symfony/security-bundle (Packagist) Fixed in 7.1.3 Advisory →
- Fix · GHSA-jxgr-3v7q-3w9v symfony/symfony (Packagist) Fixed in 6.4.10 Advisory →
- Fix · GHSA-jxgr-3v7q-3w9v symfony/symfony (Packagist) Fixed in 7.0.10 Advisory →
- Fix · GHSA-jxgr-3v7q-3w9v symfony/symfony (Packagist) Fixed in 7.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-50341
- 2026-10-03 Alias added: GHSA-jxgr-3v7q-3w9v
References
Other 6
- https://github.com/symfony/symfony/security/advisories/GHSA-jxgr-3v7q-3w9v
- https://github.com/symfony/symfony/commit/22a0789a0085c3ee96f4ef715ecad8255cf0e105
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-bundle/CVE-2024-50341.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2024-50341.yaml
- https://github.com/symfony/symfony
- https://symfony.com/cve-2024-50341
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2024-50341 · CVE Program
- CVE-2024-50341 · NVD
- FIRST EPSS
- GHSA-jxgr-3v7q-3w9v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences