Incorrect response from Validator when input ends with `\n` in symfony/validator
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
symfony/validator is a module for the Symphony PHP framework which provides tools to validate values. It is possible to trick a `Validator` configured with a regular expression using the `$` metacharacters, with an input ending with `\n`. Symfony as of versions 5.4.43, 6.4.11, and 7.1.4 now uses the `D` regex modifier to match the entire input. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | before 5.4.43; 6.0.0 to before 6.4.11; 7.0.0 to before 7.1.4 | 5.4.43, 6.4.11, 7.1.4 | Patch available | CNA |
| — | symfony/symfony (Packagist) | before 5.4.43 | 5.4.43 | Patch available | GHSA-g3rh-rrhp-jhh9 |
| — | symfony/symfony (Packagist) | 6.0.0 to before 6.4.11 | 6.4.11 | Patch available | GHSA-g3rh-rrhp-jhh9 |
| — | symfony/symfony (Packagist) | 7.0.0 to before 7.1.4 | 7.1.4 | Patch available | GHSA-g3rh-rrhp-jhh9 |
| — | symfony/validator (Packagist) | before 5.4.43 | 5.4.43 | Patch available | GHSA-g3rh-rrhp-jhh9 |
| — | symfony/validator (Packagist) | 6.0.0 to before 6.4.11 | 6.4.11 | Patch available | GHSA-g3rh-rrhp-jhh9 |
| — | symfony/validator (Packagist) | 7.0.0 to before 7.1.4 | 7.1.4 | Patch available | GHSA-g3rh-rrhp-jhh9 |
- symfony Vendorsymfony Affected before 5.4.43; 6.0.0 to before 6.4.11; 7.0.0 to before 7.1.4 Fixed in 5.4.43, 6.4.11, 7.1.4 Patch available CNA
- symfony/symfony (Packagist) Vendor— Affected before 5.4.43 Fixed in 5.4.43 Patch available GHSA-g3rh-rrhp-jhh9
- symfony/symfony (Packagist) Vendor— Affected 6.0.0 to before 6.4.11 Fixed in 6.4.11 Patch available GHSA-g3rh-rrhp-jhh9
- symfony/symfony (Packagist) Vendor— Affected 7.0.0 to before 7.1.4 Fixed in 7.1.4 Patch available GHSA-g3rh-rrhp-jhh9
- symfony/validator (Packagist) Vendor— Affected before 5.4.43 Fixed in 5.4.43 Patch available GHSA-g3rh-rrhp-jhh9
- symfony/validator (Packagist) Vendor— Affected 6.0.0 to before 6.4.11 Fixed in 6.4.11 Patch available GHSA-g3rh-rrhp-jhh9
- symfony/validator (Packagist) Vendor— Affected 7.0.0 to before 7.1.4 Fixed in 7.1.4 Patch available GHSA-g3rh-rrhp-jhh9
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | — | — | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions — — ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 5.4.43, 6.4.11, 7.1.4
- Fix · GHSA-g3rh-rrhp-jhh9 symfony/symfony (Packagist) Fixed in 5.4.43 Advisory →
- Fix · GHSA-g3rh-rrhp-jhh9 symfony/symfony (Packagist) Fixed in 6.4.11 Advisory →
- Fix · GHSA-g3rh-rrhp-jhh9 symfony/symfony (Packagist) Fixed in 7.1.4 Advisory →
- Fix · GHSA-g3rh-rrhp-jhh9 symfony/validator (Packagist) Fixed in 5.4.43 Advisory →
- Fix · GHSA-g3rh-rrhp-jhh9 symfony/validator (Packagist) Fixed in 6.4.11 Advisory →
- Fix · GHSA-g3rh-rrhp-jhh9 symfony/validator (Packagist) Fixed in 7.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-50343
- 2026-10-03 Alias added: GHSA-g3rh-rrhp-jhh9
References
Other 7
- https://github.com/symfony/symfony/security/advisories/GHSA-g3rh-rrhp-jhh9
- https://github.com/symfony/symfony/commit/7d1032bbead9a4229b32fa6ebca32681c80cb76f
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2024-50343.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/validator/CVE-2024-50343.yaml
- https://github.com/symfony/symfony
- https://lists.debian.org/debian-lts-announce/2025/05/msg00051.html
- https://symfony.com/cve-2024-50343
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2024-50343 · CVE Program
- CVE-2024-50343 · NVD
- FIRST EPSS
- GHSA-g3rh-rrhp-jhh9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences