Git does not sanitize URLs when asking for credentials interactively
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 4 fixed, 4 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When Git asks for credentials via a terminal prompt (i.e. without using any credential helper), it prints out the host name for which the user is expected to provide a username and/or a password. At this stage, any URL-encoded parts have been decoded already, and are printed verbatim. This allows attackers to craft URLs that contain ANSI escape sequences that the terminal interpret to confuse users e.g. into providing passwords for trusted Git hosting sites when in fact they are then sent to untrusted sites that are under the attacker's control. This issue has been patch via commits `7725b81` and `c903985` which are included in release versions v2.48.1, v2.47.2, v2.46.3, v2.45.3, v2.44.3, v2.43.6, v2.42.4, v2.41.3, and v2.40.4. Users are advised to upgrade. Users unable to upgrade should avoid cloning from untrusted URLs, especially recursive clones.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Git | git | up to 2.40.3; 2.41.0 – 2.41.2; 2.42.0 – 2.42.3; 2.43.0 – 2.43.5; 2.44.0 – 2.44.2; 2.45.0 – 2.45.2; 2.46.0 – 2.46.2; 2.47.0 to before 2.47.2; = 2.48.0 | 2.47.2 | Patch available | CNA |
- git VendorGit Affected up to 2.40.3; 2.41.0 – 2.41.2; 2.42.0 – 2.42.3; 2.43.0 – 2.43.5; 2.44.0 – 2.44.2; 2.45.0 – 2.45.2; 2.46.0 – 2.46.2; 2.47.0 to before 2.47.2; = 2.48.0 Fixed in 2.47.2 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:a:git:git:*:*:*:*:*:*:*:* | before 2.40.4; 2.41.0 to before 2.41.3; 2.42.0 to before 2.42.4; 2.43.0 to before 2.43.6; 2.44.3 to before 2.44.3; 2.45.3 to before 2.45.3; 2.46.3 to before 2.46.3; 2.47.0 to before 2.47.2 | Vulnerable | Git |
| cpe:2.3:a:git:git:2.48.0:*:*:*:*:*:*:* | 2.48.0 | Vulnerable | Git |
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:a:git:git:*:*:*:*:*:*:*:* Versions before 2.40.4; 2.41.0 to before 2.41.3; 2.42.0 to before 2.42.4; 2.43.0 to before 2.43.6; 2.44.3 to before 2.44.3; 2.45.3 to before 2.45.3; 2.46.3 to before 2.46.3; 2.47.0 to before 2.47.2 Vulnerable ·Git
- cpe:2.3:a:git:git:2.48.0:*:*:*:*:*:*:* Versions 2.48.0 Vulnerable ·Git
Remediation
- Fix · CNA git (git) Fixed in 2.47.2
Red Hat 4 advisories
- RHSA-2025:19601 Released 2025-11-04 · Red Hat rating Lowgit security update
- Red Hat Enterprise Linux AppStream EUS (v.9.4) git-2.43.5-1.el9_4.3, git-all-2.43.5-1.el9_4.3, git-core-2.43.5-1.el9_4.3 +12
- RHSA-2025:11534 Released 2025-07-23 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 8) git-2.43.7-1.el8_10, git-all-2.43.7-1.el8_10, git-core-2.43.7-1.el8_10 +12
- RHSA-2025:11533 Released 2025-07-22 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 10) git-2.47.3-1.el10_0, git-all-2.47.3-1.el10_0, git-core-2.47.3-1.el10_0 +12
Show 1 more Red Hat advisories
- RHSA-2025:11462 Released 2025-07-21 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 9) git-2.47.3-1.el9_6, git-all-2.47.3-1.el9_6, git-core-2.47.3-1.el9_6 +12
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:11533 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:11534 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:11462 |
| Red Hat Enterprise Linux AppStream EUS (v.9.4) | Fixed | RHSA-2025:19601 |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-50349
- 2026-10-21 Affected versions changed · Red Hat
- 2026-10-22 Affected versions changed · Red Hat
References
More Git vulnerabilities
- TI-2024-21101 Git's recursive clones on case-insensitive filesystems that support symlinks are susceptible to Remote Code Execution CVSS 3.1CRITICAL 9.1
- TI-2020-04316 malicious URLs may cause Git to present stored credentials to the wrong server CVSS 3.1CRITICAL 9.3
- TI-2022-09232 Command injection in git CVSS 3.1CRITICAL 9.8
- TI-2008-05233 The web interface in git (gitweb) 1.5.x before 1.5.6 allows remote attackers to execute… CVSS 2.0HIGH 7.5
- TI-2008-05232 The web interface in git (gitweb) 1.5.x before 1.5.5 allows remote attackers to execute… CVSS 2.0HIGH 7.5
- TI-2008-03393 Stack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in… CVSS 2.0HIGH 7.5
Sources
- CVE-2024-50349 · CVE Program
- CVE-2024-50349 · NVD
- FIRST EPSS
- CVE-2024-50349 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences