UnoPim 0.1.3 and below is vulnerable to Cross Site Scripting (XSS) in the Create User…
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
UnoPim 0.1.3 and below is vulnerable to Cross Site Scripting (XSS) in the Create User function. This allows attackers to perform XSS via an SVG document, which can be used to steal cookies.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00406 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed unopim/unopim (Packagist): 0.1.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | unopim/unopim (Packagist) | before 0.1.4 | 0.1.4 | Patch available | GHSA-hv6m-qj65-26q3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- unopim/unopim (Packagist) Vendor— Affected before 0.1.4 Fixed in 0.1.4 Patch available GHSA-hv6m-qj65-26q3
Remediation
- Fix · GHSA-hv6m-qj65-26q3 unopim/unopim (Packagist) Fixed in 0.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-50637
- 2026-10-03 Alias added: GHSA-hv6m-qj65-26q3
References
More Webkul Unopim vulnerabilities
- TI-2025-35161 unopim/unopim allows unauthorized product deletion via mass-delete endpoint CVSS 3.1HIGH 8.1
- TI-2025-35162 UnoPim Stored XSS via SVG MIME/Sanitizer Bypass CVSS 3.1HIGH 8.0
- TI-2024-34980 UnoPim Stored XSS : Cookie hijacking through Create User function CVSS 3.1MEDIUM 6.5
- TI-2025-35163 UnoPim vulnerable to remote code execution through Arbitrary File upload CVSS 4.0HIGH 7.3
- TI-2025-35164 UnoPim vulnerable to CSRF on Product edit feature and creation of other types CVSS 4.0MEDIUM 6.9
- TI-2025-35165 UnoPim Quick Export feature is vulnerable to CSV injection CVSS 4.0LOW 2.5
Sources
- CVE-2024-50637 · CVE Program
- CVE-2024-50637 · NVD
- FIRST EPSS
- GHSA-hv6m-qj65-26q3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences