UnoPim Stored XSS : Cookie hijacking through Create User function
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
UnoPim is an open-source Product Information Management (PIM) system built on the Laravel framework. A vulnerability exists in the Create User process, allowing the creation of a new admin account with an option to upload a profile image. An attacker can upload a malicious SVG file containing an embedded script. When the profile image is accessed, the embedded script executes, leading to the potential theft of session cookies. This vulnerability is fixed in 0.1.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Webkul | unopim | before 0.1.5 | 0.1.5 | Patch available | CNA |
| — | unopim/unopim (Packagist) | before 0.1.5 | 0.1.5 | Patch available | GHSA-cgr4-c233-h733 |
- unopim VendorWebkul Affected before 0.1.5 Fixed in 0.1.5 Patch available CNA
- unopim/unopim (Packagist) Vendor— Affected before 0.1.5 Fixed in 0.1.5 Patch available GHSA-cgr4-c233-h733
Remediation
- Fix · CNA unopim (unopim) Fixed in 0.1.5
- Fix · GHSA-cgr4-c233-h733 unopim/unopim (Packagist) Fixed in 0.1.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52305
- 2026-10-03 Alias added: GHSA-cgr4-c233-h733
References
More Webkul Unopim vulnerabilities
- TI-2025-35161 unopim/unopim allows unauthorized product deletion via mass-delete endpoint CVSS 3.1HIGH 8.1
- TI-2025-35162 UnoPim Stored XSS via SVG MIME/Sanitizer Bypass CVSS 3.1HIGH 8.0
- TI-2025-35163 UnoPim vulnerable to remote code execution through Arbitrary File upload CVSS 4.0HIGH 7.3
- TI-2025-35164 UnoPim vulnerable to CSRF on Product edit feature and creation of other types CVSS 4.0MEDIUM 6.9
- TI-2024-34055 UnoPim 0.1.3 and below is vulnerable to Cross Site Scripting (XSS) in the Create User… CVSS 3.1MEDIUM 5.4
- TI-2025-35165 UnoPim Quick Export feature is vulnerable to CSV injection CVSS 4.0LOW 2.5
Sources
- CVE-2024-52305 · CVE Program
- CVE-2024-52305 · NVD
- FIRST EPSS
- GHSA-cgr4-c233-h733 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences