Dell PowerStore contains an Improper Neutralization of Argument Delimiters in a Command…
Priority LOW 31CWE-88Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-88.
Summary
Dell PowerStore contains an Improper Neutralization of Argument Delimiters in a Command ('Argument Injection') vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to modification of arbitrary system files.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0027 19th percentileScored 2026-11-07
Fix Fixed PowerStore (Dell): 4.0.1.0-2408234
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerStore | N/A to before 4.0.1.0-2408234 | 4.0.1.0-2408234 | Patch available | CNA |
- PowerStore VendorDell Affected N/A to before 4.0.1.0-2408234 Fixed in 4.0.1.0-2408234 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:powerstoreos:*:*:*:*:*:*:*:* | before 4.0.1.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:powerstore_1000t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_1200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_3000t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_3200q:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_3200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_5000t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_500t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_5200t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:powerstore_7000t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:powerstoreos:*:*:*:*:*:*:*:* Versions before 4.0.1.0 Vulnerable ·Dell
- cpe:2.3:h:dell:powerstore_1000t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_1200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_3000t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_3200q:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_3200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_5000t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_500t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_5200t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:powerstore_7000t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA PowerStore (Dell) Fixed in 4.0.1.0-2408234
Timeline
- 2026-10-02 Threatist record created from CVE-2024-51532
- 2026-10-03 Alias added: GHSA-r56x-jv68-vpm6
References
More Dell Powerstoreos vulnerabilities
- TI-2026-42160 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 9.8
- TI-2022-10113 Information disclosure in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55184 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 10.0
- TI-2022-10114 Authentication bypass in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55183 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
- TI-2026-55181 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
Sources
- CVE-2024-51532 · CVE Program
- CVE-2024-51532 · NVD
- FIRST EPSS
- GHSA-r56x-jv68-vpm6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences