An information disclosure vulnerability exists in HPE AutoPass License Server (APLS) prior to 9.17.
Priority LOW 39CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-200.
Summary
An information disclosure vulnerability exists in HPE AutoPass License Server (APLS) prior to 9.17.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00453 39th percentileScored 2026-11-07
Fix Fixed HPE AutoPass License Server (Hewlett Packard Enterprise): 9.17
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hewlett Packard Enterprise | HPE AutoPass License Server | before 9.17 | 9.17 | Patch available | CNA |
- HPE AutoPass License Server VendorHewlett Packard Enterprise Affected before 9.17 Fixed in 9.17 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hpe:autopass_license_server:*:*:*:*:*:*:*:* | before 9.17 | Vulnerable | Hewlett Packard Enterprise (HPE) |
- cpe:2.3:a:hpe:autopass_license_server:*:*:*:*:*:*:*:* Versions before 9.17 Vulnerable ·Hewlett Packard Enterprise (HPE)
Remediation
- Fix · CNA HPE AutoPass License Server (Hewlett Packard Enterprise) Fixed in 9.17
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Hewlett Packard Enterprise HPE AutoPass License Server 9.17
4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2024-34672 An authentication bypass vulnerability exists in HPE AutoPass License Server (APLS) prior to 9.17.Priority MEDIUM 41
- TI-2024-34675 An information disclosure vulnerability exists in HPE AutoPass License Server (APLS) prior to 9.17.Priority LOW 39
- TI-2024-34673 An hsqldb-related remote code execution vulnerability exists in HPE AutoPass License Server (APLS) prior to 9.17.Priority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2024-51769
- 2026-10-03 Alias added: GHSA-8q9w-cqmm-hw2x
References
More Hewlett Packard Enterprise vulnerabilities
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2015-02747 Heap-based buffer overflow in Adobe Flash Player before 13.0.0.296 and 14.x through 18.x… KEVCVSS 3.1CRITICAL 9.8
- TI-2013-04219 HP ProCurve Manager (PCM) 3.20 and 4.0, PCM+ 3.20 and 4.0, Identity Driven Manager (IDM)… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2005-02634 HP OpenView Network Node Manager 6.2 through 7.50 allows remote attackers to execute… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-07113 Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before… KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2024-51769 · CVE Program
- CVE-2024-51769 · NVD
- FIRST EPSS
- GHSA-8q9w-cqmm-hw2x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences