WordPress Fancy Product Designer plugin <= 6.4.3 - Unauthenticated SQL Injection vulnerability
Priority MEDIUM 62CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in radykal Fancy Product Designer fancy-product-designer.This issue affects Fancy Product Designer: from n/a through <= 6.4.3.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.16156 96th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-51818
- 2026-10-03 Alias added: GHSA-j752-m9pw-j2v5
More radykal vulnerabilities
- TI-2021-06662 Fancy Product Designer < 4.6.9 - Unauthenticated Arbitrary File Upload and RCE CVSS 3.1CRITICAL 9.8
- TI-2024-00332 Fancy Product Designer < 6.1.5 - Admin+ SQL Injection CVSS 3.1MEDIUM 6.5
- TI-2024-00834 Fancy Product Designer < 6.1.8 - Reflected Cross Site Scripting CVSS 3.1MEDIUM 6.3
- TI-2024-00831 Fancy Product Designer < 6.1.81 - Admin+ Cross Site Scripting via Product Title CVSS 3.1MEDIUM 4.8
- TI-2024-34823 WordPress Fancy Product Designer plugin <= 6.4.3 - Unauthenticated Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.0
- TI-2021-03192 Fancy Product Designer <= 4.6.9 - Insufficient Authorization to Arbitrary Options Update via fpd_update_options CVSS 3.1HIGH 8.8
Sources
- CVE-2024-51818 · CVE Program
- CVE-2024-51818 · NVD
- FIRST EPSS
- GHSA-j752-m9pw-j2v5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences