Cross-site Scripting (XSS) Vulnerability in PasswordPusher
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Password Pusher is an open source application to communicate sensitive information over the web. A cross-site scripting (XSS) vulnerability was identified in the PasswordPusher application, affecting versions `v1.41.1` through and including `v.1.48.0`. The issue arises from an un-sanitized parameter which could allow attackers to inject malicious JavaScript into the application. Users who self-host and have the login system enabled are affected. Exploitation of this vulnerability could expose user data, access to user sessions or take unintended actions on behalf of users. To exploit this vulnerability, an attacker would need to convince a user to click a malicious account confirmation link. It is highly recommended to update to version `v1.48.1` or later to mitigate this risk. There are no known workarounds for this vulnerability. ### Solution Update to version `v1.48.1` or later where input sanitization has been applied to the account confirmation process. If updating is not immediately possible,
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pglombardo | PasswordPusher | 1.41.1 – 1.48.1 | — | No fix listed | CNA |
- PasswordPusher Vendorpglombardo Affected 1.41.1 – 1.48.1 Fixed in — No fix listed CNA
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apnotic_llc:passwordpusher:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:apnotic_llc:passwordpusher:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-51989
References
More pglombardo vulnerabilities
- TI-2026-59933 PasswordPusher before 2.11.1 Race Condition View Limit Bypass CVSS 4.0HIGH 8.7
- TI-2026-44063 PasswordPusher < 2.9.2 Passphrase Brute-Force via Unthrottled Endpoint CVSS 4.0HIGH 8.7
- TI-2026-44522 PasswordPusher before v2.9.6 Authentication Bypass via Null Comparison CVSS 4.0MEDIUM 6.9
- TI-2024-35309 Password Pusher's rate limiter can be bypassed by forging proxy headers CVSS 3.1MEDIUM 5.3
- TI-2024-37617 Password Pusher Allows Session Token Interception Leading to Potential Hijacking CVSS 3.1MEDIUM 5.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences