Password Pusher's rate limiter can be bypassed by forging proxy headers
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as `X-Forwarded-*` from clients.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pglombardo | PasswordPusher | before 1.49.0 | 1.49.0 | Patch available | CNA |
| — | pwpush (RubyGems) | before 1.49.0 | 1.49.0 | Patch available | GHSA-ffp2-8p2h-4m5j |
- PasswordPusher Vendorpglombardo Affected before 1.49.0 Fixed in 1.49.0 Patch available CNA
- pwpush (RubyGems) Vendor— Affected before 1.49.0 Fixed in 1.49.0 Patch available GHSA-ffp2-8p2h-4m5j
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pglombardo:password_pusher:*:*:*:*:*:*:*:* | — | — | pglombardo |
- cpe:2.3:a:pglombardo:password_pusher:*:*:*:*:*:*:*:* Versions — — ·pglombardo
Remediation
- Fix · CNA PasswordPusher (pglombardo) Fixed in 1.49.0
- Fix · GHSA-ffp2-8p2h-4m5j pwpush (RubyGems) Fixed in 1.49.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52796
- 2026-10-03 Alias added: GHSA-ffp2-8p2h-4m5j
References
Other 5
- https://github.com/pglombardo/PasswordPusher/security/advisories/GHSA-ffp2-8p2h-4m5j
- https://docs.pwpush.com/docs/proxies/#trusted-proxies
- https://github.com/pglombardo/PasswordPusher/releases/tag/v1.49.0
- https://github.com/pglombardo/PasswordPusher
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/pwpush/CVE-2024-52796.yml
More pglombardo vulnerabilities
- TI-2026-59933 PasswordPusher before 2.11.1 Race Condition View Limit Bypass CVSS 4.0HIGH 8.7
- TI-2026-44063 PasswordPusher < 2.9.2 Passphrase Brute-Force via Unthrottled Endpoint CVSS 4.0HIGH 8.7
- TI-2026-44522 PasswordPusher before v2.9.6 Authentication Bypass via Null Comparison CVSS 4.0MEDIUM 6.9
- TI-2024-34877 Cross-site Scripting (XSS) Vulnerability in PasswordPusher CVSS 3.1HIGH 7.1
- TI-2024-37617 Password Pusher Allows Session Token Interception Leading to Potential Hijacking CVSS 3.1MEDIUM 5.7
Sources
- CVE-2024-52796 · CVE Program
- CVE-2024-52796 · NVD
- FIRST EPSS
- GHSA-ffp2-8p2h-4m5j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences