Elasticsearch Uncontrolled Resource Consumption vulnerability
Priority LOW 30CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
A flaw was discovered in Elasticsearch, where a large recursion using the innerForbidCircularReferences function of the PatternBank class could cause the Elasticsearch node to crash. A successful attack requires a malicious user to have read_pipeline Elasticsearch cluster privilege assigned to them.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00557 46th percentileScored 2026-11-07
Fix Fixed org.elasticsearch:elasticsearch-grok (Maven): 8.15.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | 7.17.0 – 8.15.0 | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch-grok (Maven) | 7.17.0 to before 8.15.1 | 8.15.1 | Patch available | GHSA-ghfh-p92w-j4mg |
- Elasticsearch VendorElastic Affected 7.17.0 – 8.15.0 Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch-grok (Maven) Vendor— Affected 7.17.0 to before 8.15.1 Fixed in 8.15.1 Patch available GHSA-ghfh-p92w-j4mg
Remediation
- Fix · GHSA-ghfh-p92w-j4mg org.elasticsearch:elasticsearch-grok (Maven) Fixed in 8.15.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52980
- 2026-10-03 Alias added: GHSA-ghfh-p92w-j4mg
References
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-52980 · CVE Program
- CVE-2024-52980 · NVD
- FIRST EPSS
- GHSA-ghfh-p92w-j4mg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences