Read the docs
TI-2024-35717 Aliases CVE-2024-53253GHSA-v5h2-q2w4-gpcx

Sentry's improper error handling leaks Application Integration Client Secret

Priority LOW 31CWE-209Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-209.

Summary

Sentry is an error tracking and performance monitoring platform. Version 24.11.0, and only version 24.11.0, is vulnerable to a scenario where a specific error message generated by the Sentry platform could include a plaintext Client ID and Client Secret for an application integration. The Client ID and Client Secret would not be displayed in the UI, but would be returned in the underlying HTTP response to the end user. This could occur under the following conditions: An app installation made use of a Search UI component with the `async` flag set to true (default: true); auser types types into the Search Component which creates a request to the third-party for search or query results; and that third-party response may then fail validation and Sentry would return the `select-requester.invalid-response` error code along with a serialized version of a Sentry application containing the integration Client Secret. Should this error be found, it's reasonable to assume the potential exposure of an integration Client Secret. However, an ID and Secret pair alone does not provide direct access to any data. For that secret to be abused an attacker would also need to obtain a valid API token for a Sentry application. Sentry SaaS users do not need to take any action. For Sentry SaaS users, only a single application integration was impacted and the owner has rotated their Client Secret. No abuse of the leaked Client Secret has occurred. As of time of publication, a fix is available for users of Sentry self-hosted in pull request 81038. Sentry self-hosted does not ship with any application integrations. This could only impact self-hosted users that maintain their own integrations. In that case, search for a `select-requester.invalid-response` event. Please note that this error was also shared with another event unrelated to this advisory so Sentry self-hosted users will also need to review the parameters logged for each named event. Sentry self-hosted users may review `select_requester.py` for the instances where these errors can be generated. With the security fix this is no longer a shared event type. Sentry self-hosted users may not install version 24.11.0 and instead wait for the next release. Self-hosted instance that are already running the affected version may consider downgrading to to 24.10.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00645 51st percentileScored 2026-11-07
Fix Fixed sentry (PyPI): 24.11.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getsentrysentry= 24.11.0—No fix listedCNA
—sentry (PyPI)24.11.0 to before 24.11.124.11.1Patch availableGHSA-v5h2-q2w4-gpcx
  • sentry Vendorgetsentry Affected = 24.11.0 Fixed in — No fix listed CNA
  • sentry (PyPI) Vendor— Affected 24.11.0 to before 24.11.1 Fixed in 24.11.1 Patch available GHSA-v5h2-q2w4-gpcx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sentry:sentry:24.11.0:*:*:*:*:*:*:*24.11.0VulnerableSentry
  • cpe:2.3:a:sentry:sentry:24.11.0:*:*:*:*:*:*:* Versions 24.11.0 Vulnerable ·Sentry

Remediation

  • Fix · GHSA-v5h2-q2w4-gpcx sentry (PyPI) Fixed in 24.11.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-53253
  2. 2026-10-03 Alias added: GHSA-v5h2-q2w4-gpcx
  3. 2026-10-14 EPSS moved to the 50th–90th percentile
  4. 2026-10-18 EPSS moved to the below the 50th percentile
  5. 2026-10-20 EPSS moved to the 50th–90th percentile

References

  • TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
  • TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
  • TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
  • TI-2025-16094 Improper authentication on SAML SSO process allows user impersonation in sentry CVSS 3.1CRITICAL 9.1
  • TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
  • TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
See all 28 →

Sources